Sketchup Make 2017 no longer getting access to 3D warehouse

I used to be able to access models on 3D warehouse, but Sketchup just hangs when I open it.

Can you be specific?

  • Are you using the 3D Warehouse window (with the website) or the Components Browser in the tray/side bar?

The Warehouise only supports current minus two versions. The 2017 format was removed over a year ago. You can open Warehouse in a browser and download as Collada (.DAE) and import that into your Sketchup.

Same issue here with SU17 when trying to open the 3dwarehouse window … butt when using the component library search option, one can still find and download 3dwarehouse models :wink:

Hi Aerilius, sorry for the delayed reply. I’m trying to open the 3D warehouse from the tray/side bar. I can click on ‘Get model’ but then sketchup displays a general screen that doesn’t allow me to do anything. I used to be able to download models directly from there.

I’ve tried logging on to 3D warehouse on the website and downloading a random model, which works, but i don’t know how to open that model from sketchup.

Hi Anssi
Thank you for your response. I’ve tried your suggestion and get this error message.

I’d love to use a later version of sketchup that doesn’t have these issues, but it seems that none of them are free anymore, is this correct?

Thanks for your help AnnoNiem, where is the component library search option in SU17? Is it supposed to be under the 3D library menu? I can’t find it.

Since you are using SketchUp 2017 Make I assume you are a hobbyist. If you want to use content from the 3D Warehouse go to the Warehouse in your internet browser and download the Collada version of the objects you’re after. Then import the included .dae file into SketchUp.

Will have to anser without SU17 at hand … (only have SU17 a@ home)

If you do not see the component window/tray, you can open it from ‘window/default tray/components’
image

This wil open the component window/tray where you can search components, also from the 3dwarehouse.

Worked the last time i’ve tried, hope it stil works.

update 20220829:
Just tried to download one of my models using the component search, is no longer working.
When trying to download a model, it only shows error messages ‘not found or invalid’ and an error occurred.
image
image

So wil have to use the 3dwh website more often when using SU17.