SketchUp Make 2017 Components / 3D Warehouse offline?

Dear all,
since some months i am using the Make 2017 Version installed on my Windows Computer for private usage. All this time (till ~2-3 weeks) i was able to integrate prepared components via the “Components” windows in my model. I just searched the required furniture in the search-bar and double clicked the displayed icon. A a small pop-up windows appeared and downloaded the component into my model as a component.
(see picture below … sorry for the german wording, dont know how to switch it to english …)

However, since some weeks this is not working anymore.
Searching is still working like before, all the components are display. But after double click on the icon the following error messages appear:

“File not found or invalid”

“Error during the connection to 3D Warehouse”

I know that 3D Warehouse is not working with Make 2017 anymore. However, the component window was functional some weeks ago. So maybe the issue is on my side? As far as i am aware i did not change anything… Does anyone else have this problem?

Best regards and thank you!

Edit: I searched in this forum for solutions. One hint was to click on the icon, not on the text in the component window. However, same result: Clicking on the icon the error messages above appear. Clicking on the text a 3D Warehouse windows opens (but i know that this is not longer supported by Make 2017)

There may be more than one thing going wrong. I tested by search for poliform Zoe, and then trying to insert this one:


It works ok on Mac in 2017, but in Windows it fails with the error you showed in 2017, and fails silently in all other versions - up to 2022.

@TheGuz is it correct that Windows 2017 users cannot download from the search results in the Components tray, even though Mac users are allowed to? That aside, what is it about this model that makes it fail in all versions of SketchUp on Windows?

It didn’t fail for me but it inserts a long way from the origin.

On Mac I saw that too. On Windows, the Components tray did not show any new entries, and shift-z zoomed in tightly around the scale figure.

Weird. Odd that it wouldn’t load for you.

There seems to be a related issue with SketchUp for Schools. Models download ok on Mac, but with Windows it fails in Windows 11 under Parallels, works in Windows 11 on a mini PC, works in Windows 10 under Parallels, but fails on a Windows 10 desktop PC.

Hard to tell what the pattern is.

Same here, could use the 3dwarehouse from within SU17 using the component search option. Tried again few days ago and failed.
They got it fixed again!

I made a little tutorial to download models on the 3D Warehouse and import them for 2017, if it can be useful to you.
Display Subtitles

Thank you for the video! The same way i am currently doing it. But, the way using the component window worked totally fine some weeks ago. Really annoying to have this time consuming workaround now …


We can see what was changed that caused the new problem. Trying to get the team for that feature to fix the issue.

Some news…

There was a change in the 3D Warehouse that doesn’t relate at all to SketchUp 2017, but it had a side effect, where some users would seem like they were not authorized to download components.

That unrelated change has been reverted for now, until it can be put back in place without the unintended side effect.

Getting components from the components tray/panel should be working again.


good news, wil give it a try this evening :+1:

more good news, it works again, thanks for the repair!

I just tried it. Its working again and i can integrate components in my Make 2017 model. Thank you alot for the great and quick support!!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.