SketchUp Hangs when opening new file from the startup dialogue

Hi, I recently installed the Sefaira plugin on vSU 22.0.354.

When i opened the sample .skp file from the startup dialogue window, the SU application freezes with the menu greyed out (see screendump)

When i open SU with a blank template, then FIle > Open, it works

It has the look of a dialog opening offscreen, I don’t have sefaira to check what the dialog might be but you can try the old offscreen key combination to check.
When it hangs, press alt and space together, then tap m, then tap any arrow key and finally without clicking, move the mouse around until a dialog appears, click to finish.

1 Like

Hmm, I tried the keys combination, still no response… when i changed my display settings to only one monitor, i saw an extra dialogue… however when i ‘X’ that dialogue, the screen is still in frozen state.

What was that dialog?

welcome to SU dialogue

And what happens if you choose a template rather than x out of it?

I can’t replicate that anymore, only way is to force kill via windows task manager

It really sounds like an offscreen dialog issue, are you sure you are doing the key combo correctly?
I have moved the thread to the sefaira category to attract their attention. And I’ll Ping @niraj.poudel , he may be able to say what dialog is needing input from you.

yes, press and hold Alt and Space, then tab m no response at all

Just in case.

This magic combo wizardry works like a charm on my chrome browser… but ALT +Space doesn’t bring up any menu in SU.

Thanks for the help!

If alt space shows nothing then it must be opening offscreen. If you use alt space while SU has focus the menu will appear at the title bar, or if the focus is on chrome it will appear there. If it isn’t showing then it must be opening on an offscreen dialog.

the only thing Alt Space + M is doing on my SU session is bringing the underline shortcuts on the menu bar… no response when i hit any Capital Key

image

You aren’t doing alt and shift by any chance?

Double checked… i’m not…

Well there is something going on that is strange. You can see in this gif that alt will turn the underscores on, which I hit a few times, but add in spacebar and you get the menu as well.
So that menu must be attached to another dialog if it’s not showing there.
GIF 1-04-2022 3-40-07 PM

I’m lost for anything else to suggest, except perhaps a repair of the installation. Wont affect settings toolbars or extensions, just cleans up in the background.
If you want to try that. Find or download a new copy of the install.exe, select and right click it and choose Run as admin, then repair when given the option. Reboot the PC and try again.

1 Like

Maybe describing it in other wording:
https://forums.sketchup.com/t/lost-default-tray-on-2nd-monitor/148192/6?u=dezmo

Follow this guide exactly after opening SU

  1. Hold down the ALT key. Hit SPACEBAR.
  2. Release ALT key
  3. Hit M (Move).
  4. Hit one of arrow keys
  5. Move your mouse around (without pressing any mouse key) until you see the missing window.
  6. Press left mouse button on the desired place

( Note I assume you have English windows otherwise you may need to replace “M” with a localized letter, e.g. “L” in French)

2 Likes

Try this:
Open SketchUp (one instance only)
Wait for all the extensions to load.
Sign out through [menu] Help > Signout (emailaddress)
Then Sign back in.

Try to activate the dialog via the menu
[menu] Extensions > Sefaira > Show Dialog

Now try the alt space combo

The reason for signing out first and back in is to be sure the contacted servers have the right tokens.
Otherwise, it can be ‘hanging’ and loose focus for the alt space to work.

2022-04-01_14-49-38
Here’s a replication of the issue… you can see that i also tried “File Open” and it also hangs…

The GIF shows me clicking in the graphics area, and then the menu buttons with no response. I had to force kill.

Here is the second GIF with no issues, and following the STEPS you listed (Using another file)

no issue