Problem opening older files in sketchup 2022. Program stay unresponsive

I have problems when I try to open a file made in an earlier version of sketchup. When you open a file program made all the openig process, displays the design but once you click everywhere it report an audible error sound and the program became unresponsive, to get out you have to go to task administrtor and kill the sketchup proces.
I read for an identical problem at this closed post: Sketchup 2020 Unresponsive When Opening Older Files
i did the modifications to the shared preferences.json but in my case it didnt work. I aprecciate you help!!

Try this variation on my comment in the post you linked.
Open the file, once you hear the warning sound, hold down alt (not alt gr) and tap Spacebar, release alt, then tap up arrow twice followed by enter, tap any arrow once and then move the mouse without clicking until the warning dialog shows, click to place and then click ok to accept.

This is what you are trying to do, imagine this dialog is opening where you can’t see it, the various key taps navigate to attach the dialog to the cursor.
The double arrow up avoids possible language differences where m is not the default for move.

2 Likes

I like your up arrow solution to take care of whatever language is in use.

still, not every language has the same options in the same order, it is best to check what shortkey is used in the specific options with a dialog that is onscreen, al ready…

image

mine says maximize with two up arrow taps and additional arrow key taps does nothing.

Capture d’écran 2023-01-19 165243
same for the french version, two taps give maximize, five taps give move

and our shortcut is L :slight_smile:

Note, my comment is for the warning dialog and may well be different to the 3d text dialog. But whatever ffs.

haha it’s even worse in french.

I just tried with an old file, you’re right, two taps. And this time the shortcut isn’t L anymore, it’s D.

D Ă©placer
dép L acer

come on windows developers :sweat_smile: !

The point being that the original poster should try the option I suggested in his link but exchange m in my sequence for whatever is the correct default option for move in his language, assuming his system isn’t set to English.
It may not solve the problem.

I was trying to suggest a language agnostic option. I guess it doesn’t work.

1 Like

thanks for helping me, unfortunatelly i could not solve the problem. My system is in Spanish, i tried with tap on up arrow, also typing an M like your original post but nothing happend :frowning:
is very frustrating because other colleague works with the 2018 version so i have to open a empty file, then import the model and then explode it and save as another version for my coleage can wrk on the modiications i made. Is lot of time wasted.
Another idea?

If it is opening off screen you need to find what is the default shortcut for Move in Spanish. It isn’t always the first letter of the word.
If you open any window and right click on the title bar you will get a menu, look for what would be the Move option and try that letter instead of M.

Thanks for the video, indeed i confirmed that letter M is to move in spanish as it is in english.
Problem is that i made the sequence:
open file (no sound nor alert)
click at the model to select something
error sound
press alt NOT altgr and hold
tap space bar
release alt
Nothing happend nor see
tap up arrow twice
enter
nothing happened
tap arrow left
move mouse
Nothing happend
for a whole minute moving

if i clik again, thats the sound again.

its frustrating!

When you hold Alt, tap spacebar, release Alt, nothing visible will happen.

Don’t tap up arrow, because M will work for you.

Tap M. Tap any arrow key, move cursor.

I tried that too but nothing happend. I asked to support and they found that there was a problem with extensions, once I uninstall all extensions except trimble conect the program started to work fine, i installed again all extensions and now i can not find the sefaira extension that y have previously. So, o solve the problem, but y can not use the Sefaria at the program, i have to use it on the web. I will update data if i found more. Also accept ideas on where to install sefaira.

Do you have a (payed) plan for usage of Sefaira?

ahhh.

I’ve think seen a bug in Sefaira where it brings up a dialogue during installation to accept terms and conditions - if you don’t accept this by closing the pop-up it breaks and you can’t open SketchUp.

from memory we think we had to fully uninstall Sefaira (and maybe even SketchUp) and then reinstall everything again - looking out for this screen during that process to make sure we accepted it

EDIT.

It’s scan essentials, not Sefaira.

I just had an experiment
I just created a similar situation for myself and at one point I was getting this message + bonging

Educational Studio has Sefaira and no V-ray and Scan Essentials.
Commercial Studio doesn’t have Sefaira but has the other two.
NFR for resellers have all three.
The bootstrap error you saw could only be resolved after a reinstall of Sefaira, I believe.
I was assuming that the OP has a commercial Studio without Sefaira, but there might be something else going on…

The installer for Sefaira is here : You can access it if you have a Sefaira subscription, which it sounds like you do
Section 2A: Accessing Sefaira with the SketchUp Plugin – Sefaira Support

Thanks for the invaluable help of everybody at this forum. Finally the reseller where i purchase the licence found the problem. I use to have a plugin call 1001 bit tools since 2015 version so i look for it and installed. It never make me any problem till i need to work in an external skp (my original problem) So. The solution was only to deactivate the extension and now everything is working fine.
Again, thanks for the help.
Regards!

thanks!!