Open / import / all dialog pop-ups not working


#1

So, any of the dialog boxes such as open, import, or various ones in V-Ray that require viewing files outside of SketchUp only work the first time, but then I can’t get them to come up after that. I have to restart SketchUp to use it again (but then still only get one shot). I’ve repaired disk permissions and recently done a clean reinstall to no avail.
… Anyone? I’m stumped
Note: this is not the issue of the material or styles etc dialog showing, this seems to only happen when the dialog box deals with files.

SketchUp Pro 2015 15.3.329 (latest)
Mac OSX 10.10.2 Yosemite (latest)
Also have the newest V-Ray installed, if that matters.


Issues with importing - need to restart Sketchup to import each time
#2

@cedric, simple question…
did you look behind SU for those missing?
john


#3

Check out a helpful article:

  • [Retrieving a missing dialog box.][1]

Hope this works!
AlexB
[1]: http://help.sketchup.com/en/article/1040897


#4

Thanks, both, for your reply.

I hope I can be a little more clear - I don’t have a problem with the dialog boxes missing (the common problem where the floating style, shadow, component, scene etc boxes disappear). In the case of the ‘open’ dialog it isn’t even a true window, just a box that slides down from the top of the screen. But no matter how it looks, if it deals with a file outside of SketchUp (importing, opening, or importing materials in V-Ray) it won’t show…

@john_drivenupthewall, I did try all of Mac’s different ways of looking for application windows behind but found nothing. I don’t use two monitors, but I do have two ‘desktops’ in the way that OS X allows through Mission Control. And nothing shows up in the other desktop either.

@AlexB, I gave it a shot just to be sure, but it didn’t work. I tried the ‘Bring all to front’ button too, but nothing.

I’ve used SketchUp for almost 10 years, not that I’m immune to a goof here and there, just a bit of background on me. I’ve seen a lot of bugs over the years but I’ve never had this happen. I wonder if anyone has had the same problem, I haven’t found mention of another instance anywhere yet…


#5

I have this exact same problem. Only one chance to open the access screen.

Working in Layout, I can only import one SketchUp file and then I have to save, shut down, and restart to get the next reference drawing imported. I can go to my Mac’s finder window, and double click to open a SketchUp file. I work on a MacBook Pro early 2011, and have over time had Lion, Mavericks, and now Yosemite on it.

Three weeks ago, the laptop was taking 5 minutes to boot up, so on the advice of a co-worker, I manually backed up my files, (not Time Machine, so I can’t go back) wiped the drive and did a clean install of Yosemite. MISTAKE!

I tried re-installing SketchUp tonight… no plugins… and it still doesn’t work. Everyone else at work (5 people accessing the same files on a server) does not have this problem. I think in some strange way, either the OS is interfering with the route to the “open” dialogue box, or the older versions of SketchUP (2013 and 14 were also on the earlier successful interaction) made some kind of map that made that screen open. I am beyond frustrated. My work flow speed is half what it usually is.
HELP! please? any other ideas besides what’s noted above?


#6

If it really is a MacBook Pro early 2011 and NOT the Retina MBP’s from 2012 ignore this, but we’ve had 3 or 4 go out with kernel panics from the GPU.

After that, see what’s being a pig on the machine using Activity Monitor or top in a bash shell (I order by CPU first). Then look at memory usage (and enough room to swap-to-disk), then network traffic speeds compared to other machines. A trip to the Genius Bar might be helpful.


#7

Yeah it seems to be a relatively new glitch. I didn’t notice whether it started when I upgraded SketchUp or my OS though. For posterity, I’m on a late 2008 Macbook Pro


#8

A 2008 may be getting long in the tooth for 10.10. We have an old iMac in our lab, and when we put a 10.9 image on it, it was too painful to use at times.

You could try a cleaner install on Mac. A couple of things to clear:

~/Library/Caches/com.sketchup.SketchUp.2015*
~/Library/Saved Application State/com.sketchup.SketchUp.2015*
~/Library/Preferences/com.sketchup.SketchUp.2015*


#9

I cleared those, no change. There was actually nothing for SketchUp in the Saved Application State folder.

My macbook actually runs Yosemite really well, I think it’s the best operating system since whatever it came with (Snow Leopard?) But it could see how there might still be something straining the hardware somehow.

I clean-installed Yosemite less than a year ago, so I’m reluctant to do that, but there’s always a possibility it could help. If I get desperate I might.


#10

@cedric,
do you have the same issues without VRay?
do you know if it has it’s own .plist…

I don’t have it, so I can’t check for myself…

john


#11

are you sure you cleared them? were all of your preferences etc reset to default values upon re-launching sketchup?
as in, did sketchup look and act like a brand new sketchup after you trashed the files?


#12

Oh, forgot to mention - preferences from p-lists are cached by cfprefsd (Core Foundation prefs daemon), so you have to kill that, too.

I’d still see what’s being the pig using top or Activity Monitor.


#13

@john_drivenupthewall I’m also wondering if it happens without V-Ray installed, I’ll try uninstalling it after the .plist / cache experiment.
And V-Ray does have its own .plist
So I cleared:
com.asgvis.V-Ray For SketchUp
com.sketchup.SketchUp.2015.LSSharedFileList
com.sketchup.SketchUp.2015
And I did find a file for V-Ray in the Saved Application State folder, cleared that
com.chaosgroup.Users.vlado.savedState
and the Cache folder for SketchUp, once again.

No, maybe not, @Jeff, it didn’t reset to defaults afterwards. So, question: is it enough to dump these files in the trash or is there some terminal command I should be executing?

And then a few things for @Barry:
what about this daemon you mention? You’re saying it recreates the .plist files as soon as I open SketchUp, and that’s a problem? Also, how do I ‘kill it’? I’ve run a stop daemon command before but I don’t feel comfortable enough to just start typing randomly in terminal…

And I monitored the CPU usage as I started SketchUp, opened a file, and then imported a material in V-Ray, and then also while it was failing to import/open after that, and nothing seemed to change, nothing seemed excessive. I can drop the screenshots from any of those times here if that would help.


#14

@cedric
what I would look for is the Vray plist updating,
it seems to me it may start out ok, then looks for a ‘path to first folder’ the second time… not finding one it fails to load…
check permissions on the .plist…

re: the daemon, if you delete any plist, the daemon recreates it, putting you back to where you were…

if you use ‘Terminal’ with defaults delete <plist> then it also clears the daemon as well…


#15

Oh yeah, that makes sense! I think you’re on to something. The .plist permissions seem fine though.

I had to finish some work so I couldn’t spend time on this last week, but through some experimenting today, I seem to have narrowed it down.

So, I can replicate the issue only when
com.asgvis.V-Ray For SketchUp.plist
is present. Once V-Ray creates the file (usually upon importing a V-Ray material, but not always) I get the issue, or if the .plist file is present, upon opening SU without touching V-ray, I get one shot at open/import/new texture and then I get the issue.

But if I delete
com.asgvis.V-Ray For SketchUp.plist
I don’t have the issue, up until V-Ray re-creates the .plist file, at which point import/open/new texture immediately stop working.

So it does seem to be the V-Ray .plist that is screwing with things, but what is curious is that it doesn’t cause the problem when SU is first opened.

Does anything think killing the daemon through Terminal is still something to explore? If so, I’m still unclear how to do that…


#16

make both a before and after copies of the Vray plist, then either see what’s changing or post them…

use ‘Terminal’ with defaults delete <add path to Vray plist>
after first run of Vray make the first copy…
make the second after using Vray ‘open file’ and
make a third when it fails…

john


#17

I am NOT using Vray and I have the same issue… I recently upgraded to Yosemite… now SU2015 will NOT import files… ok to drag and drop…

help, help, help…


#18

what kind of files are you trying to import?
how (exactly) are you trying to import them?
what happens when you try to import?
what do you expect to happen when importing?
etc.


#19

Jeff,
thanks for the quick reply

First, Mac Mini, 2012… plenty of ram… long time SU user…

Typically a pdf file, screen shot, jpeg file… in this case a plot plan…
I go to file… import… No dialogue box shows up…
so technically… NOTHING happens…
Like what I use to do… it would give me a choice of files, file type… a dialogue box… it does not show up now…
this is a recent and most annoying glitch… please please please do NOT tell me to reload and loose all my scrapbooks, templates, plugins… for the 4th time.


#20

are you using sketchup 2015? (make or pro)…if so, read on… if not, what version of sketchup are you using?



ha. ok, not that bad but it will reset your preferences…
templates will stay, scrapbooks will stay, plugins will stay, shortcuts will stay.

things that will change are – custom preferences such as which template to open upon launch, which toolbars are on or off (after resetting sketchup, all of your toolbars will open when relaunching)… etc.

so, there’s a little bit of reconfiguring after resetting but it’s not too bad.

if you want to reset:

• Quit SketchUp
• open Terminal (Applications/ Utilities/ Terminal)
• copy&paste or type the following line into the terminal window then press <return>

defaults delete com.sketchup.SketchUp.2015

relaunch sketchup… it will look and act as if it’s the first time you installed it (though as i said earlier… your plugins etc won’t be deleted)