Sketchup Freezing and working very slow, even with simple models

Hi,

I had this issue for a while, did not manage to reach any help from Sketup support.

Device:
MacOS
Big Sur 11.1
Processor 2.7 GHz Quad-core Intel Core i7
Graphics Radeon Pro 455 2 GB

Sketchup Pro 21.0.392

Problem: The navigation is very slow, it keeps freezing, the loading wheel on the mouse pops up every few minutes and It’s almost impossible to work with more complex components.

I reinstalled my entire laptop, updated the OS and it feels like it’s even worse than it was before.

Suggestions?
Much appreciated.

What is a “simple model” in your definition? How many edges and faces, how many components and groups? Can you post a .SKP model file, or a screen-shot of one?

If the current scene has Profiles and/or Shadows turned on, try turning them off. This generally speeds up the rendering of the SketchUp viewport considerably.

Turn of autosave in the preferences, does it improve?

Great questions, thank you.

Where do I find the info on edges and faces, how many components?

Model Info>Statistics, check the Show Nested Components box.

Thanks, here it is:Screenshot 2021-02-28 at 19.06.47

Almost three million edges, 1564 component instances? I wouldn’t call that a simple model.

How about sharing the .skp file so we can take a look?

Thank you so much.

Upload doesn’t seem to wanna work.

No surprise considering your file size is about 12 or 13 times the max file size. Hang tight.

So here’s what I see. First, yours is not a simple model.

Incorrect tag usage. ALL edges and faces should be untagged.
Screenshot - 2_28_2021 , 12_25_37 PM

Lots of unused stuff to purge.
Screenshot - 2_28_2021 , 12_27_00 PM

That reduced the file size by nearly 54%.

Reversed faces that need to be corrected.

There are a number of components that appear to have come from the 3D Warehouse that could be reduced. when using components you are downloading from the Warehouse you should download them into a separate file to check and clean them before putting them into your model.

Thank you very much for your help, sounds like I need to invest a bit of time in understanding these things, Much appreciated.

1 Like

The model is massively overloaded with very heavy entourage elements, probably from the 3D warehouse. The worst offender is the set of 12 chairs (Cadeira Husk B&B…) which together contribute 1,819,584 edges. Next worst is Group#321 (looks like a mixer) which has 325,528 edges. Then the bicycle, with 279,170 edges.

I could keep going, but that’s enough to show the issue. These imported models are way too detailed and are bringing your computer to its knees. You should at minimum give them a tag that you can turn off, or better, replace them with simpler proxies until you are finished developing your model, have final scenes set up, and ready to render.

On another note, if you switch to monochrome mode you will see that a large proportion of your faces are reversed, showing gray-blue back side color instead of white. You should correct their orientation before applying materials, as materials will mask this situation, but many renderers will show only the front sides of faces.

In addition to what the others said, the spinning cursor does happen while auto save is going on. You could go into Preferences, General, and set that to be less frequent. It’s odd that the cursor kicks in, and I will ask colleagues to take a look to see what it is about the model that makes it so hard to save.

Between auto saves you could make the smoothness of working on the model be a lot better. Go to View, Edge Style, and uncheck Profiles. You will be shocked at how much smoother it becomes.

Here’s a sofa for you to try. It’s the one you are using, but reduced to 1/3rd of the number of edges and faces.

sofa.zip (7.0 MB)

For the chair, here is a version someone did that is 1/4 the size of the official one:

CADEIRA bebitalia_husk_outdoor