Sketchup For Schools needs Admin Approval

hi

I get the application needs approval from an Admin before use for Sketchup for schools. I’ve looked through all the posts and found these steps

  1. Open Microsoft 365 admin center
  2. Open Azure Active Directory (show all)
  3. Enterprise applications > Manage > All applications
    click + new application and find “SketchUp for Schools”
  4. Sketchup for Schools > Properties
    Enabled for users to sign-in = yes
    User assignment required = no
    Visible to users = yes
  5. Enterprise applications > Manage > User settings
    Users can consent to apps accessing company data on their behalf = yes
    Users can consent to apps accessing company data for the groups they own = yes
    Users can add gallery apps to their Access Panel = yes
    Users can request admin consent to apps they are unable to consent to = no
  6. Wait 60 minutes and then even a non-admin account should be able to use Sketchup online

After doing all that and waiting a while I still get the error.

Do I need our domain Whitelisted too and is there some documentation regarding that?

Thanks

Even after completing the authorization steps t’s possible that your domain still needs to be whitelisted. Certain school domains (.org, .edu, etc.) get flagged as commercial or higher-ed accounts even though they belong to a K-12 school. If you could share the domain(s) used by your school’s faculty and students I will add them to the whitelist for you.

Thanks Grant, I’ve added your domains so please give it another try. Hopefully this does the trick!

hi, it’s still saying

SketchUp for Schools needs permission to access resources in your organization that only an admin can grant. Please ask an admin to grant permission to this app before you can use it.

Am I correct in assuming that you have admin privileges for your school? From your earlier post it sounds like that is the case but if not you will still need to ask your admin to approve the permissions for SketchUp for Schools.

Yes I’m the admin, how do I do that?

Thanks
Grant

Hi Grant,

Are you able to sign into the app under your administrator’s account? I’ve included below a different set of instructions for you to try that may help. You should be able to give permissions directly through the app, so please let us know if this does or doesn’t work for you.

  1. Make sure you are completely logged out of Microsoft. This isn’t normally necessary but will reduce the numbers of errors that could occur when logging in for the first time. You can use Chrome’s Incognito Mode, Firefox’s Private Browsing, or Edge’s InPrivate mode to guarantee that you aren’t logged in anywhere.

  2. Access the application via https://edu.sketchup.com/app and select the “Sign in with Microsoft” option when prompted.

  3. A pop up window should appear. Make sure it isn’t hidden behind the main browser window! If a pop up window does not appear make sure your browser allows pop ups for the edu.sketchup.com domain and reload the webpage.

  4. Next, complete Microsoft’s login workflow using an administrative account for your domain.

  5. Once you select the “Consent on behalf of your organization” and click “Accept” students should be able to login to the application also! If you see a different window it may mean that you are not using an account that has application consent permissions for your organization.

hi

When I use my onmicrosoft admin account to login to the https://edu.sketchup.com/app page it works but goes directly to the “welcome to Scetchup for Schools!” there is no way to grant access for everyone in my emmanuel.qld.edu.au domain in the app settings. Any other ideas as the senior teachers are very keen to use this as part of their curriculum.

Grant

hi, I see now that I have to use my top-level admin account to allow this. I am concerned about how much access the app needs. Can you please clarify from this photo below what the app actually needs/does?

Also, what do schools do that don’t have Microsoft or Google?

@Tori_SU can you please help with the about questions?

How did you get to this permissions screen. I have tried the top level account but it still logs me in with no option of giving permissions?
This is far from easy!!

I can get past that using the top-level admin user - but my concern is just how much access the app is asking for… and if schools don’t have google or O365 how do they use this? Not getting much help from the moderators here…

@firebladez My apologies for not seeing this sooner, I’m glad that you were able to find the permissions screen.
To clarify, these permissions are used by SketchUp for Schools to allow the program to save user files to their One Drive and to retrieve and update the files when they make changes. For privacy reasons, we do not store any SketchUp for Schools user data internally, and so these permissions make it possible for you and your students to create, save and edit project files from One Drive accounts.

@RobJ Are you still having difficulties with access?

ok cool thanks for getting back to me Tori - I have enabled using our uber O365 admin and the app is now working for the school… ta

1 Like

Thanks but all sorted for now. I got our IT dept to have a look and they have sorted it.

2 Likes

Hi There,

Sorry to nudge this thread but despite all my efforts and granting permissions. Only an Admin is able to sign in the edu.sketchup.com portal. Staff/Students are being advised that an admin needs to grant permissions yet this has been done.

I have specified the groups (and individuals in Azure AD, installed the App in Google Admin etc) but no luck

Can you please advise further please?

Thanks

Cookie/Kaushik

hi @Steve_Ketchup please whitelist our domain: cap.education

Hi can you please whitelist our other school tenet - josiah.qld.edu.au

thanks

Hej Steve!

Jag får exakt samma problem som personen ovan att jag inte lyckas skapa ett konto, trots att jag laddat ner sketchup till google. Hur får man sin skola vitlistad? Vi önskar gärna kunna använda denna tjänst denna veckan när eleverna ska skapa sina egna butiker i ett projekt i skolan,

Tacksam för hjälp!

/Sofia Larsson, sofia.larsson03@molndal.se (Krokslättsgymnasiet).
Min gmail är soflar04@gafe.molndal.se om man vill ha google-kontot.