SketchUp for Schools Login Changes for G Suite Users

Hello SketchUp for Schools G Suite users!

You may have noticed recent changes in the login behaviour of SketchUp for Schools. This is because Google has made some alterations to their login procedures that require users to review and reaccept user permissions.

In the case of SketchUp for Schools, this means that your school or district IT Administrator will need to reaccept application permissions on behalf of your domain. The steps to do this now look a little different, and to help make things clearer we have outlined them below:

  1. Sign into your school’s domain using an administrator account.
    Important Note: Make sure this is an ADMINISTRATOR account with the ability to provision apps for your domain.

  2. Navigate to Google Marketplace, then search and select the SketchUp for Schools app.

  3. At the top of the listing, just below the SketchUp for Schools title, click the button reading ‘Domain Install’ to load the application permissions.
    Please make sure that you have pop ups enabled.

  4. Allow the app and accept the permissions to enable it for your domain.

Once you have accepted permissions for your school, students and teachers will be able to access SketchUp for Schools by selecting the app from the “waffle” app menu in Google Chrome or by visiting: edu.sketchup.com

*Important Note: Whitelisting a domain name is only required in rare situations where a domain is mistakenly identified as not being an education domain. It DOES NOT remove the requirements for your district administrators to give application permissions, and you will not be able to access SketchUp for Schools until these permissions are granted.

Could someone Pin this in an attempt to help people see it.

ok thank you i did that. does sketch up need to add our school district to their whitelist. i did see people requesting access from sketch up to use sketch up for schools. if so then please let me know.

The whitelist is only a requirement in cases where your domain is misidentified as not being an educational domain. For the majority of cases it is not necessary and it does not replace the requirement for admin permissions. If your students are still having access permissions please let us know!

@Tori_SU
We are still having issues with students being able to log in. For some reason our teachers don’t seem to have this issue. Attached are the screenshots our IT department sent me. They’ve even tried removing SketchUp completely and reauthorizing it. Any thoughts I can pass along to them?

@bsteinbach Google changed the process. The IT department needs to go to the actual marketplace listing (not the console) and click “Domain Install”. Installing the app is now a separate process vs authorizing it. If that still doesn’t work, Tori can do additional debugging with you in a direct message.

Edit: I see a link in one screenshot saying “add app to domain install list”. That may also be a way to fix this?

We are having an issue where we log on and a pop up appears asking us to sign in with Google then verify the email address then it loops back to the sign in with Google. I have revoked access and granted access again. There is only the uninstall option in the Marketplace

Any suggestions?

We’re still having the same issue with teachers being able to log in, but it seems like students can not. I misspoke about “authorization”. Our IT department followed your directions above, even after removing SketchUp completely. Our teachers are able to log in, but students are not. They also added an allow install to see if that might fix it…

We are having the exact same issue, teacher fine but students cannot.

@bsteinbach & @chris.jenkins

Are students and teachers logging in with email addresses with the same domain?

yes. ours is @birdvilleschools.net

Students get the message “are you in the right place?” with a Google sign in button that just loops back to the same page when they select their user account.

Thanks, I’ve added your domain to our whitelist which should resolve the error. Can you please check again and let me know?

1 Like

Yes it works now, thank you!

We have domain installed (verified in the Admin console) and I have granted all permissions.

We are stuck in the “Sign in with Google” --> Choose an account --> “Are you in the right place?” --> “Sign in with Google” -->… loop.

Is it because our school domain does not end in .edu? Is that the way Sketchup for Schools is filtering educational institutions?

We were able to use the service and have half a dozen class sections actively using it for current classes. Can we please be added to the whitelist?

Thanks,

Yes. Students and teachers are both under the @nssd112.org domain.

@dkbrooks

Sorry - I have no idea why your other post has been marked as spam but we’ll look into it!

I’ve added your domain (http://lincolnacademy.org/) to our whitelist which should resolve your login issues. Please check again and let me know if this does the trick!

@bsteinbach You are all set!

I’ve followed the steps to re-grant access. What URL do I grant pop-ups on?

Also, my domain is lkstevens.wednet.edu, I believe it needs to be whitelisted.

EdS

Do you need to whitelist our domain too? sanjuan.edu and student.sanjuan.edu. Seems we were getting similar errors