Sketchup failed to open document! can someone help me

i am opening this file, and this shows up. Can someone help me retrieve this? its almost months of hardwork :frowning: @colin hoping you could help, found youve helped with the same problem


Don’t double post. That just creates confusion. It’s against forum rules, too.

sorry :frowning: just a bit desperate for this file.

I tried to open it but SketchUp told me it isn’t a SketchUp file. Maybe Colin will be able to do something with it but it isn’t even 6 am where he is. He probably won’t start work for a few hours.

have been opening this file on multiple computers. then when i opened this file, the notif showed up.
gosh :frowning: i have worked on this model the longest time already huhu

Where have you been saving it when working on it? A cloud location?

its saved on a external hard drive.

Probably a failed or interrupted save corrupted the file. Did you try opening the .skb file?

yes. i tried to open it on the same computer. i remember i saved it, and its not opening as well, same notif. :frowning: now i cant open both files :frowning:

Well, hopefully Colin will have some luck. Most often with corrupted files what he is able to recover is components and materials.

yes i am hoping :frowning: huhu

Unfortunately, the file is 140 MB of FF values. If you zip compress the file you will see that it comes down to 140 KB. Look to see if there is a .skb backup file in the same folder.

i already opened the skb file a while ago, and saved it on the same computer. its not opening again.
i have reuploaded a new file, with 56 mb, can you work with this? or do i need to zip the file?
im really sorry for the hassle, and thank you for your assistance.

i have uploaded another file, 56 mb ( i think because i hide some of the tags.)

That one is almost entirely empty as well.

At this point it sounds like you’ll need to start over on this model. Save it on an internal drive to avoid potential connection problems.

:frowning: why is it empty though?

We can only guess but based on experiences other have had, it’s probably due to an interruption in the connection to the external drive during a save or autosave. Thenormal advice is to save your project to a local (internal) drive. If you need to move it to use on another computer, copy the saved file to the external drive.

Halo dave, i have a same issues about failed to open document in my sketchup version 2021.
can you help me about it? i’ll share my sketchup file on wetransfer link.
thanks for your help @DaveR

I’ll look and see what I can do. I’m about to start with a student so it may have to wait a bit. What version of SketchUp are you really using? Your profile says 2021 Make which is not possible as there never was such a version.