Sketchup detected multiple graphics cards bug

Hello hows everyone doing, to start off I’d like to make everyone aware that I’ve got a Dell Optiplex 3010 SFF specs can be seen in the link below. After installing sketchup I noticed jagged line which I did not like, I was told to pick up a nice graphics card to fix the issue. I got a GeForce GTX 1050ti, installed it without a hassle and opened sketchup, to my surprise the jagged lines were still there. Whenever I open sketchup I get an error window popping up I ignore it by pressing continue. I was told to look into the openGL settings where you can select the graphics card but I get an error whenever I go into it I’ve tried messing around in Graphics Settings are selecting the sketchup app then setting the card to the 1050 but that doesnt help it I also tried going into the Nvidia Control Panel and changing the settings there but nothing helps

Here’s the link to the error window, specs and so on https://imgur.com/a/9HW9egt

Jagged lines: https://prnt.sc/th4ush

If anyone could help me fix the jagged lines I’d really appreciate it, this has been bothering me for quite some time now.

Thanks :slight_smile:

Please post a model showing the jagged lines you are seeing. that will help you to get an answer faster that guessing.

yes sorry forgot about that one https://prnt.sc/th4ush here it is thanks!

How about the .skp file, just drag the saved file into the reply window. By the screen shot I would try going into preferences, open GL and increase the anti aliasing one step at a time to try to eliminate the jagged lines, mine is set to 4X.

You must run sketchup with the new graphics card - you error message say that you still use the intel graphics.
Right click on the sketchup icon and select run with graphics processor and choose the Nvida card.
image

what .skp file sorry?

I dont have that option for some reason?

I also dont have the intel graphics driver installed as there’s no such thing for my processor

download (3)
This messages say it clear: sketchup is using the integrated intel card.
BTW: did you run sketchup in a VM-Ware-Environment?

Run with graphics processor missing:
https://nvidia.custhelp.com/app/answers/detail/a_id/5035/~/run-with-graphics-processor-missing-from-context-menu%3A-change-in-process-of

I’m not exactly surew what you mean by “did you run sketchup in a VM-Ware-Environment?” sorry

I’m looking into that link you sent me thanks

Are you running SketchUp in a virtual machine or a remote desktop system? The problem with these (in addition to licensing limitations) is that not all support OpenGL. Your screenshot shows a reference to VMWare that is one of the vendors of these systems. AFAIK not all versions of VMWare support OpenGL. @SketchUp3D_de might have some more information.

In your opengl details is noted: “OpenGL Vendor VMWare, Inc…” - thats let me guessing a VM-Ware is used…
When sketchup is running with the correct card your opengl details should look like this:

I dont have the option to add in the “Run with graphics processor” icon on my nvidia control panel, i did however add the sketchup application to open up with the 150 graphics card in the Graphics Settings but unfortunately that didnt fix it. I also dont have the option to switch the card preferences in the nvidia control panel

You must select sketchup or add sketchup in the step 1…

Im running sketchup on my Dell Optiplex 3010 SFF which has windows 10 installed on it

Yes I did but thats an image from the internet heres mine i dont have option number 2

Ohh i see it now thats strange Screenshot_3

Im running the application on my Dell Optiplex 3010 SFF which has windows 10 installed on it

maybe you need to update your graphics driver for the card.
Something is strange on your system:
sketchup say you are using integrated graphics
opengl is from vmware
nvidia does not show the card selection step

For that version of the Nvidia control panel, the setting you need to change is “OpenGL-rendering GPU” (it is further down when you scroll the list). Set that to point to the Nvidia card instead of automatic selection

I updated all my graphics card drivers yesterday. I cant seem to find any graphics driver for my intel 2500 processor though

Changed it just there and im still getting the same issue for some reason