Edges and lines appear jagged or "stepped"

I’ve just bought a new Dell 7700 AIO desktop with Windows 11 and I downloaded Sketchup Make 2017, which I’ve used extensively before on a Windows 10 laptop. All new lines I draw using my new Dell appear jagged (see attached). When I open my old Sketchup files (created with my previous Windows 10 laptop) they are perfect - but when I add new lines they appear jagged or stepped. I’ve tried different screen resolutions on my new Dell but this doesn’t make any improvement. I’ll be so grateful for some help, I can wait to take advantage of my new 27 inch screen to work on Sketchup.

This is a graphics card thing. Experiment with the settings in Window>Preferences>OpenGL.

I am having the exact same issue. Nothing I’ve tried so far has worked. This has included:

Restarting the computer.
“Repairing” sketchup.
Reinstalling sketchup.
Updating the driver.
Reinstalling the driver.
Using Nvidia control panel to force anti-aliasing.
Changing settings in Preferences>OpenGL.

This was not an issue before, my graphics card is more than capable, and all system checks tell me I should be able to run Sketchup without issues.

It’s just like Sketchup can’t use hardware acceleration anymore, and I don’t understand why. There seems to be no rhyme or reason to it. One day it anti-aliases everything perfectly, the next day there’s zero anti-aliasing, regardless of settings.

Probably worth mentioning: I am having issues in other applications, for instance with blurred text in my browser (Brave). One thing I have not tried yet is using DDU to wipe the driver and start again from a clean slate. I will be trying that next.

Okay just a quick update, using DDU to wipe the driver and reinstall from scratch has fixed the issue. Here are the steps I took:

Download DDU here: Display Driver Uninstaller (DDU) V18.0.3.6 Released. - Wagnardsoft Forum

Press win+r > msconfig > boot > safe mode (minimal)

Close and restart

You will now be in safe mode. Extract DDU, it will put a folder where you extract it. Open it and run DDU, select: Clean, do not restart, and use the following settings: DDU_Options.png - Google Drive

When DDU finishes, exit and do win+r > msconfig > boot > uncheck safe mode. Restart. Your computer will now boot back into normal mode.

Download Nvidia 442 driver (or relevant ATi driver).

Disconnect your internet. Run driver installer. Select “driver only”, custom install, uncheck everything except the driver.

Restart.

Reconnect internet. Sketchup anti-aliasing should now be working.

Thanks Scott for your very comprehensive reply.

You previously reinstalled your graphics driver and that did not work. How is your final solution different? Did you install a different driver?

I’m not as tech savvy as you obviously are and I’m nervous about making changes (that I don’t fully understand) to my brand new computer. Since my computer is new and I haven’t done anything that could have corrupted it, I cannot understand why anti-aliasing is not working correctly. If I make the changes you describe will they have any impact on other software on the computer?

What graphics card do you have? Mine is Intel(R) Iris(R) Xe. Do you think your solution will work with my graphics card?

I’m very grateful for your help.

The solution is different because it takes the extra step of wiping all the graphics drivers off the computer, and doing a clean install from scratch. That is what the DDU software does, it completely wipes the graphics drivers - for some reason, “reinstalling” doesn’t really do that, it leaves some original files on the computer rather than starting fresh, therefore corrupted files can remain despite the “reinstallation”.

My graphics card is an Nvidia GeForce 1060 3GB, but this process should work for all cards in theory.

As for why a new computer isn’t working correctly, I think it’s most likely that this problem has actually been caused by a recent Windows update. I don’t know why, but for some reason Windows updates are bad for causing graphics drivers to become corrupted. It’s not the first time I’ve experienced a computer that just “suddenly won’t render graphics properly”. Usually a driver update fixes it, but I guess in this case that wasn’t enough.

My recommendation to you would be to do a manual installation of the driver for your card which you can find here: Intel® Iris® Xe MAX Graphics (96 EU)

Run that, reboot, and see if that fixes your graphics issue.

It does work for all video drivers.

Sorry about delay in response but I’ve been away for a few days.

I’ve been following the guidance given by ScottK (for which I’m very grateful) but I when I start to put my computer in safe mode I get a warning message about the BitLocker Drive Encryption and informing me that I need to make a record of my recovery key (which I have done) to reinstate the BitLocker when I come out of safe mode. I’m nervous about messing about with BitLocker - is it absolutely necessary that I go into safe mode in order to run the DDU software?

Incidentally, I tried uninstalling my Intel graphics driver (without running DDU) and manually reinstalling the latest Intel driver, but like ScottK found, this did not solve the problem.

Yes it is.

Are you using any 2nd monitors, Docks or USB adapters relating to your monitor?

Problem sorted, many thanks to everyone for their help. I worked through the solution that worked for ScottK but it didn’t work for me - thanks anyway Scott. In the end I paid more attention to the advice from DaveR and revisited windows>preferences>openGL. I found that the “Multisample anti-aliasing” box was showing 0x. I changed this to 16x and problem solved. I now feel embarrassed that I was stumped by such a simple thing but perhaps my experience might help someone else with the same issue. Thanks again to all.

1 Like