Jagged again lines with 4K monitor


#1

I previously posted this problem and got some help but then everything went bad again.

I have a 4K monitor (3840x2160 pixel resolution). However, rather than getting a lot of detail with nice smooth lines I see very jagged lines (like the higher resolution is just showing me the jaggedness).

I am running a Dell XPS 15 9530 with Windows 8.1 64 bit
NVIDIA GeForce GT750M 2 GB RAM
Intel® Core™ i7-4702HQ CPU @ 2.20GHz 4 Cores
16 GB RAM
SketchUp 8 Pro

I was able to help this problem with some adjustments in NVIDIA control panel which then allowed me to select 4x Anti-Alias in SketchUp Preferences. This helped a bit. I recently updated the NVIDIA drivers (auto-update) and now I can only get 0x Anti-Alias with terrible jaggies.

I went to the NVIDIA Control Panel and made the changes shown below.
o Manage 3D settings
 Global Setting tab.
• Settings: Click on Anisotropic filtering.
• Click down arrow. Select “16x”
 Program Settings
• Line 1 Select a program: SketchUp
• Line 2 Select “High-performance NVIDIA processor
• Line 3. Select “Anisotropic filtering Use global setting (16x)”
However, SketchUp Preferences will now only show 0x Anti-Alias.

Anyone know what to do?


#2

Can you also check out: When right-clicking on the SketchUp application launcher icon → properties, what is set for “dpi scaling on high-dpi settings”?


#3

Here is a screenshot. “Disable display scaling on high DPI settings” is unchecked. There doesn’t seem to be any other option than disable (which is not done)


#4

And when you disable it?


#5

No improvement when I disable it.

I did a system restore to get me back to before the NVidia driver update.

Now I have 4x anti-aliasing and much better line quality (although it has never been as good as I think it should with this monitor).

I sent a question to NVidia.


#6

Hi Huckrorick,

I am facing the same problem as you do. Do you have any solution to the problem?

attached is my screenshot of the sketchup program when it is running. The icon are super small and is extremely straining to the eyes. =(

Regards,
Arthur


#7

Hi, Please look at the previous posts on this question. I used the NVidia control panel to set anti-aliasing to 4X
I think there was another setting I used but I don’t remember now.
These improved things but I have never been fully happy with the results.
If you are using a Dell XPS laptop with high resolution screen, the only thing that really helped with the size of icons was to set resolution to 1920x1080… crazy when you have a high resolution screen, but at high resolution text and icons are not readable. Hopefully software designers will fix this in the future. There are some Windows setting that help with some programs, some times.

To set text size and screen resolution:

Control Panel (“Appearance & Personalization”, “Adjust Screen Resolution”, click on “Make text and other items larger or smaller”, under “Change only the text size”, set Title Bar, Menus, Message Boxes, Palette titles, Icons and Tooltips to a larger size (I like 12 pt), Click “Apply”).

Or
right click on desktop, select “Screen Resolution”, click on “Make text and other items larger or smaller”, under “Change only the text size”, set Title Bar, Menus, Message Boxes, Palette titles, Icons and Tooltips to a larger size (I like 12 pt), Click “Apply”

Can also change overall text scaling.