Jagged lines after adding another monitor

Hello, I have a problem with jagged lines in SketchUp 2020. I have the program for quite some time and everything was fine until recently when I added another monitor. Now my lines are thicker and really jagged it is hard to even work because with some small faces lines even merge. I tried changing multisample anti-analising but it still stays the same. I have a decent graphics card so i know that is not the problem. I could really use some advice because i dont know what else to try. Hopefully someone has came across a similar issue.

This is how it looks on my higher res monitor.

What are your graphics settings?

What version of SketchUp are you really using? You put “Free Plan” in your forum profile. There is no free version of SketchUp 2020. Are you using a cracked version?

Sorry my bad I just made account bassicaly clicked the first suggestion that poped out i use SketchUp Pro 2020 i believe that is what you ask. Sorry I am new to all this can you please explain me what do you mean by graphics settings

SketchUp 2020 has Preferences, inside which are OpenGL settings. In there you can change the antialiasing to a higher value. At the moment you are set to 0x, for your RTX GPU I would expect it will go to 16x or even higher. Depending on your monitor there isn’t a need to get excessive with the setting. Each level up you go can then be more demanding for SketchUp or the GPU. Try 4x, then 8x, then 16x. Stop at the point that you’re happy enough with how smooth the edges are.

That is the thing i dont understand even if i change it to 16x it doesnt make a difference. I was searching for a solution for few hours and every fix was to change antianalising. That is why i decided to write here on forum i really dont know what else to do I even tried tampering display settings but that didnt help either. It is really weird even when I just try to make a simple line it is jagged while i am making it.

With the latest SketchUp you do need to close and reopen SketchUp for the changes to show. With 2020 I thought it changed right away.

Can you say in what way you are using SketchUp 2020? If it’s a Classic license there is a chance you may have been under support still when 2021 came out. I don’t think that had any antialiasing related fixes it in, but it certainly did have some improvements worth having.

You could try SketchUp 2024, for 7 days, see if the antialiasing works in the current version.

If you have set 16x, and closed and reopened SketchUp 2020, and it is still set to 16x, but the lines are jaggy, you have a problem we haven’t seen before!

You should still have to quit and restart SketchUp to get the change to take effect.

Please correct your forum profile.

Yea i did that as well, i read it on one of the suggestions while i was searching for solution.

I already corrected my profile sorry for the missunderstanding.

I tested that, no, you didn’t have to quit.

Going back to my question about whether you are on a Classic license. The email address you use in the forum doesn’t have a Classic license. You can message me by clicking my avatar, and choosing Message, to tell me the email address you used for the license. Or let me know the serial number. It would be a private message, other people won’t see your details.

Alright. That was a long time ago.

When I look at your video my lines are far worse even with 16x, maybe my problem is not antialisaning ill try to update my drivers or something i dont know what else to do. If i manage to fix it I’ll let you know thank you for all help, I appreciate it.

1 Like

We’re both pretty old by this point…

1 Like

The screen recording I did smoothed out the 0x edges a bit. For me, they were completely jaggy. The 16x were something on the lines of what the screen recording showed.

You should still tell me about your license, if 2021 is available to you, and might have had some fixes in it, you should install it.

Do the lines look jagged on only your second monitor? Does the second monitor use a larger scale factor than 150%? Is the second monitor connected through a laptop “dock”? Some of those only use your computer’s integrated graphics instead of your graphics card.


Your photo of your screen clearly shows a sketchup window that has no anti aliasing at all. Interestingly, it looks lower resolution than the cursor itself. It’s really hard to tell since you used a camera and not a screenshot.

I only mention this because with a truly high res display, you can barely see jaggy edges with no anti aliasing. That’s actually how I run sketchup regularly ans anti aliasing crashes the software immediately for me.

Is this a 4k or 5k display, and are you set at that resolution? You might have to change resolution or anti aliasing settings with your video card itself, or update drivers.

1 Like

I may have made a mistake when defining my problem, since english isnt my primary language I refered to the problem as lines being jagged but I found another topic on the forum and they called their lines distorted and when I looked at the picture they provided lines were exactly the same as mine. They managed to fix the problem by updating their GC drivers or checking that feedback button in OpenGL but for me that didnt help either. Maybe this could explain why changing antialiasnig didnt fix my problem. Maybe I am trying to find a solution for a problem I dont even have.