Viewing problems. Lines not solid


#1

I have a new DELL Inspiron 13 7378 Two in One to use in my shop. It ostensibly has the requirements Sketchup needs. I’ve run the Sketchup application to confirm. All clear and working properly, except it isn’t… Dell Tech support has updated the drivers, installed, uninstalled, etc. They said all is working great and they could do no more to fix it. The display is still “shaky”. They asked I contact you for a fix.

I hope you can help. Thank you for your time. The whole purpose of this laptop was for this program…


#2

I gather you are referring to the jagged appearances of the edges. That is due to the anti aliasing settings for your graphics cards card. What version of SketchUp are you using?

Look in Window>Preferences>OpenGL. Can you select a different, higher anti alias setting?

Unfortunately Intel graphics cards, which according to Dell is what your computer has, are well-known to be weak in the OpenGL department.


#3

Yes. The jagged lines. It’s very hard to look at without getting dizzy and difficult to see the cuts I need to make from the drawing. Not sure how accurate the dimensions are.
I’m using Sketchup 2017.

I’m really bad with tech stuff. How do I select a different alias?. Sorry, don’t have a clue to what that means… There is no window-preferences. Is it settings I need to look at?
Thank you


#4

On the application menu, click the Window menu, choose the Preferences item.
On the Preferences dialog, select the OpenGL panel.

On this panel, there will be a Capabilities list, which will have your current setting highlighted (according to the control highlight settings for your system.)

You’ll see that the lst column is labeled “Anti-Alias”. Basically “0x” is none. The higher the number, the smoother the lines, but the more work the graphics card needs to do, so the slower the display response will be during panning and orbiting.

To make a change select one of the other capabilities.
Then, after any change, restart SketchUp.


#5

Thank you. I was looking everywhere in Windows 10 for anything that said "preferences/open GL. LOL I’ll try it. What # do you recommend for my system?


#6

I found what you recommended. It won’t let me increase the number from 0X.


#8

These are pre 2017 opengl settings and are different in 2017.

I suspect your graphic card isn’t fully compatible with 2017. You may get a better result with 2016.
Failing that, change the laptop for one with a better graphic card.


#10

@eriley1811, Lizbeth, It may be that your a victim of having the very latest (rather than obsolete hardware.)

Your processor is the latest 7th generation Intel iCore APU
with the latest Intel HD (Iris Pro) 620 integrated graphics.

What graphics driver version do you have installed ?
(There are a few driver updates at the Dell Support for your product.
They are naturally a bit behind the Intel drivers.)

http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-13-7378-2-in-1-laptop/drivers


There is a relatively new Intel OEM beta driver available.


FYI:


#11

Thank you all for the support. I have a Dell Technician about to call and I’ll inform him of your suggestions.


#12

Follow up: Dell fixed the jagged lines. It had to do with screen resolution. I had increased to 150% because I don’t see well. He returned it to 100% and most of the jaggedness has disappeared. Unfortunately I can’t read the small print in the default trays…


#13

Well, I guess I wouldn’t have thought about the screen resolution change. Can you attach a larger monitor?


#14

This is actually called “display scaling”. And only partly has SketchUp been made compatible with it, and only up to 150%.

This is a statement by Tommy, just after the SU2016 release. More improvements were made in SU2017.

@Tommy, is this jagginess logged as a known issue for display scaling of 150% ?


#15

If you have an extra display, and you’re at home. You might plug it in, (extend your desktop onto it,) and drag the trays over onto the extra monitor. Then set the extra display to a higher scale.

But beware! Don’t disconnect the extra display without first dragging and redocking the trays back to the internal display.


#16

Fabulous idea THANK YOU!!


#17

For the money, it can not be beat! I bought one just for SU myself! (I like things larger for my old(er) eyes as well!)


#18

Yea, I’m running with a 25" HP Pavilion LED display plugged into my notebook, and have it set as the primary display. I use the internal 15" to display reference documents in Chrome browser, and File Explorer windows, etc.


#19

I took a look through the bug database and didn’t happen across any such issue. @thayer – Have you come across aliasing in SketchUp 2017 on Windows 10 with the display setting at 150%?


#20

@Tommy I’ve not seen aliasing like this with 150% scaling on Win10.


#21

@eriley1811, it sounds like Dell was able to fix your issue which is terrific. For future reference, here is a bit more information about the OpenGL settings you tried to change.

When you tried to change your Multisample anti-aliasing setting (from here on referred to as MSAA) from 0x to 2x, SketchUp was unable to tell Windows to recreate the SketchUp window with 2x MSAA and fast feedback support (see the “Use fast feedback” checkbox in your screen shot). In this case, you can try unchecking the “Use fast feedback” checkbox and selecting 2x MSAA (or even 4x or 8x). Some graphics cards do not support both MSAA and fast feedback at the same time (you can have one or the other but not both) and I believe this is the situation you have encountered here.


#22

@thayer @Tommy @jody

There is no page that corresponds to this error message, and has this excellent information thayer gives, under this Help Center section:

… nor on this Help Center page:


Also, a search in the Help Center doesn’t give any good hits for the term “display scaling”, and nothing appears on the following page, to help users understand how they can (and should not) use display scaling with SketchUp. (ie, SketchUp versions supporting what % settings, what features are scaling aware / what are not, etc.)

Perhaps the subject of display scaling deserves it own page, under the Customizing SketchUp section ?