[Graphics] Edgy and jagged lines


#1

lines are appearing edgy and jagged in sketchup model, even when i am rendering the edgy lines are there. what should i do, have already reinstalled it, already changed settings, nothing is working. i am uploading the pic of the model, please help me guys.


[Graphics] AMD/ATI Radeon - Dotted grid on startup
#2

What style is applied ? Window > Styles

What are the OpenGL settings ? Window > Preferences > OpenGL


#3

it is set at default style.


#4

Which lines are you reffering to? The roof looks like a texture, this would explaint the appearance in a render…


#5

Check that you have the latest graphics driver version installed.

Check in your graphics card control panel that its 3D settings are compatible with SketchUp

  • check that SketchUp is set to use your graphics card instead of possible integrated graphics
  • check that your Antialiasing and Anisotopic filtering settings are set to “Application controlled” or equivalent

After that and restarting SketchUp you might have other choices in the Capabilities window in SketchUp’s OpenGL settings, so you could try using a setting with 2x or 4x antialiasing. Now you only seem to have the choice of 0x (no antialising).

Anssi


#6

No it’s several of the vertical lines.
Just to the right of the first door from the left.

Then again to the right of the second door from the left. There are even more “jaggedy” vertical lines between the window panes.


#7

Too few pixels for these fine lines in the jpg? Single lines or more complex geometry? How does the rendered version looks like?


#8

The good old trick can still be used when exporting image files:

Export your image without antialiasing to a higher resolution (pixel count) than you r final image needs to be, and downsample it then in your image editor. Photoshop and other image editors do much better antialiasing than SketchUp.

Anssi


#9

Hi there
when i get my image into photoshop ( and this doesn’t matter if its png or pdf )its very blurry,how do i get to the settings you mentioned:

Check in your graphics card control panel that its 3D settings are compatible with SketchUp

  • check that SketchUp is set to use your graphics card instead of possible integrated graphics
  • check that your Antialiasing and Anisotopic filtering settings are set to “Application controlled” or equivalent
    my model looks nice but certainly has some jagged lines…
    I’m on a mac.

#10

I haven’t used Macs since OS X was published so I cannot help you here. Probably SU should run quite OK on Macs with the default system settings. Inside SketchUp, I understand, the OpenGL dialog (Preferences>OpenGL) is approximately identical between the Mac and PC, and you can select an antialiasing level within SU from the options available there.

Blurry output may depend on that you have Antialiasing set both in Preferences and the Export Image options. I usually have all antialiasing turned off. Nowadays I export usually from LayOut where I have the option of using Vector or Hybrid rendering that gives me resolution-independent crisp linework independent of raster graphics settings.

Anssi


#11

jevottamsharma
Aliasing is a artifact of sampled data systems and related to what is called the NyQuist limit and and if adequate filtering is not used before sampling you will hear strange audio noise and see jaggies you have noted. Video manufactures try and minimize the effects and I would be surprised if AMD does not for its graphics. I have a NVAIDIA card and can set it up to 16x but going beyond 4x I do not see much improvement.
Are you allowed to post your model and also let us know the SKU version of the graphics.
Thanks


#12

I am using mac.
It will be better exporting pdf because pdf keeps vector line (edge).
I can edit line weight by vector editor like illustrator, inkscape, cad (exchanged pdf to dxf/dwg), etc.

When exporting image format (jpg, png), I have to decide image size and resolution at option setting dialog (ex. 3000x3000, 600dpi)

When exporting pdf format, I only have to decide line weight (ex. 0.25pt) which is editable by vector editor, and I can decide resolution at importing image editor like photoshop, gimp, etc…

sample image is 600dpi antialias on, 600dpi antialias off, 0.25pt line weighted pdf

lineweight_025pt.pdf (2.4 KB)


#13

I figured it out,(some of it )
I cranked up the image size in sketchup export… bingo nice and crisp.
i still am wondering about how to set line weight.
also how to check that my graphics card runs optimally w SU…
Nvidia geforce 750
thanks to everybody for the effort.


#14

@lars,

you can only adjust the AA setting on a mac using Ruby Console or a plugin…

the code is simple…
first check what it is…

Test.get_AA_method

should return 0,1,2,3, or 4 [default is 0]

Test.set_AA_method(4) # is the highest available

you can try other values…

john


#15

Hi John
i typed the suggested in to ruby console, one by one,( i have zero experience w ruby)
here is a copy the ruby box

Test.get_AA_method
0
Test.set_AA_method(4)
0

it may be me but it seems that if anything that my lines got rougher, ( may just being paranoid about messing something up)
did i do this right??


#16

yes, if you do the get test again it will show it has been changed to 4…

This used to be the defaults setting, but was changed to help with an ATI card issue a couple of SU versions back…

If you don’t notice the difference after re-starting SU, do you have any system ‘power saving’ settings in use?

I normally model using the 0 setting and switch over to 4 for printing raster images…

I always set my model window to match the paper ratio of the printer…

john


#17

Thanks John , It does show 4…
I was confused by the 0 after i had set it to 4.

I’m curious does it slow your machine down running it on 4 or do you have other reasons.
Lars


#18

my iMac is getting very old [mid 2007] and only has ATI Radeon HD 2600 Pro 256 MB…

it’s amazing it runs El Capitan and SU v16 at all, and I sometimes need to nurse it a little…

john


#19

John
I restarted Su and its SUUUUUPER crisp I am getting no jagged lines or “pixellation” whatsoever, no matter how much i zoom.
This helps me so much.
thanks for your help
take care of that old lady of yours.
Best
Lars