Need help trying to get "better looking/smoother" models to present to clients

I’ve got an issue where all my models look lo-res with jagged lines. I’ve been looking at my graphic card (GTX 2060) settings and OpenGL/anti-alias settings. I did have my graphic card set to “best performace” and I changed it to “optimal power” and it helped a little but it’s still not clean.
I messed with a bunch of style choices as well and I can’t seem to figure it out. Maybe it’s my workflow.

Here’s the model I’m working on, it’s a little funky, but I have the same issue in all my models.
https://drive.google.com/file/d/1GkzMHVJUsp-AM9l6D-kaYbwl5sIdOIQb/view?usp=sharing

Can’t look at your model because you have it locked up.

Try now:

That worked, I am seeing the model. The cylindrical location image is badly pixelated but that’s in the image file. You have a style set that shows edges, but It’s not clear that this is what you are talking about. Can you post a screenshot of what you are calling jagged edges so we can understand what you are trying to fix?

Is this closer? A quick editing of the style.

I see your background is extremely low res. I also see Z-fighting as on the wall in the center of the screen shot and almost all of the windows.

I expect you could do better with some of your textures such as the one used for the walkway and the steps.

Here’s a PDF of two images – the top image is before I changed my graphic card settings, the bottom is after.
Doc2.pdf (240.8 KB)

DaveR, I’m not worried about that background, It’s more the linework in the model. The worst of it being the vertical lines in the siding. Each of those lines is separate geometry as I build it “board by board”, then exploded all the nested groups and applied a material to it. So I have a hidden “master house” floating up above where I can make structural changes if I need to, but the geometry on the “concept” layers have been exploded in order to apply materials easier. Don’t know if that affects it at all, I would assume it doesn’t.

Ideally, I’d like it to be as clean as this example …https://3dwarehouse.sketchup.com/warehouse/v1.0/publiccontent/86bfe2b1-7824-4a77-be42-d03b67a84029

I was thinking something more along the lines of this style:
https://3dwarehouse.sketchup.com/warehouse/v1.0/publiccontent/86bfe2b1-7824-4a77-be42-d03b67a84029

Yes, that z-fighting was something I was wrestling with throughout, I did a lot of cheating to get it passable for the client. That said, ignoring that, the jagged lines are still an issue on other models. In this model I get the jagged lines on walls where there is no z-fighting … like if I turn off the “2. Wall systems” tag folder it makes the whole model hollow. But nothing on the siding (the tan vertical siding) changes visually. The siding is in the “12.Concepts” tag folder.

You have horrible z fighting because most of the model is just flat surfaces on top of one another. You can’t layer things in 3D and expect one of them to “win” out on top like a 2D program. The thing you want to see must physically stick out past the other object.

I get that, but it’s 3D groups stacked. Like there’s a cube as the building. Then 3D siding on top of that. I know some of it is flat, but the z-fighting is happening on the siding, which is 3D groups.

It makes no difference if the objects are grouped. They cannot occupy the same space as another piece. Your windows are doing the same thing.