A way to smooth line edges..?


#1

(I realize I kept appearing here often, sorry about that, I’m quite new with sketchup ;-; )

I am trying to take a screenshot of my model to print out but I noticed that some of the lines are not straight when I rotate the model to a certain perspective. Is there a way to make the lines straight?
I am bad at explaining so here’s a picture and I’ve circled parts of what I’m talking about ^^;


#2

Why are you taking a screen shot? Why not export an image directly?


#3

o.o I meant exporting to jpg sorry, I am used to saying screenshot ^^;;


#4

Have you tried exporting a PNG instead? And tried increasing the size in Options?


#5

I tried png and doubled its pixel size but the lines are still jagged(Not much difference from jpg). Could it be that I need to adjust it in sketchup cad first? Cause my models are showing jagged lines( due to me rotating it in a perspective angle)


#6

What is “sketchup cad”?

There’s nothing to adjust In SketchUp for image exporting other than in Option in the Export window.


#7

e.e My apologies, I use other modelling software too so I kept referring software as cad.

I meant the sketchup itself, when viewing the model, the lines are jagged


#8

I know you are seeing the lines as jagged. Your graphics card has a lot to do with what you’re seeing on screen. You can only get as good as your graphics card gives.


#9

Do you mean you want them vertical,
if so, you need to select “two point perspective” from View Pull down menu


#10

My apologies for the extreme delay, I was occupied with work
Yes that’s what I meant and it worked, thank you!


#11

May I know which type of graphic card gives better performance? I am keen to change my card if that will improve my overall graphic quality
(I tried my best to type, sorry if my english is bad)


#12

The jaggedness of the lines is controlled by anti-aliasing.


In SketchUp …

Open Window > Preferences > OpenGL
Click the “Graphics Card Details” button.

Verify that the Vendor is AMD, and the Renderer is your AMD Radeon GPU.
IF not, use an AMD utility to set SketchUp.exe to use your high performance AMD GPU.

IF so, check the “Multisample anti-aliasing” choice and increase it to a higher setting.
(For example, my Nvdia GTX1060 has these choices: 0x [none] 2x, 4x, 8x, 16x.)

The higher the anti-aliasing, the slower SketchUp will render scenes, but the better they will look !

With some graphics systems and some SketchUp versions, you may need to close and reopen SketchUp to have the settings take effect.


#13

Thank you for the detailed explanation and link to the video, I really appreciate it!