Jagged lines on 2d export

I got a new computer to improve my sketchup issues, but I have new ones now. Perhaps you could help

Lenovo Think Station
12th Gen Intel(R) Core™ i9-12900 2.40 GHz
32 gig ram
windows 11 pro
ssd 1000 gb samsung drive
Nvidia T1000 graphics card with Benq Mobius monitors

Sketchup Pro 2023

On my 8 year old Dell, I would choose export animation, turn off scene transitions, and wind up with a jpg of each scene that looked like the sketchup screen.

Now when I export either from animations or one at a time, the resulting jpg, or png file has jagged edges. Same result in various export settings, file type selection. I have tried the google results for this issue and have tried many settings in Nvidia Control Panel, but to no avail.

Here is the export version with jagged lines

And here is a screen shot with straight lines

I have read most of the google results other folks who have had this issue, and adjusted all that I saw with no result.

In my nvidia control panel, I do not see the option for preferred graphics card - just base profile . Also in the Sketchup preferences,I don’t see an option for openGL that many suggest to adjust.

Thank you for your time. Any help is much appreciated.

Thomas Huntington
Huntington Construction LLC

At what size are you exporting the images?

Have you tried exporting from LayOut? You would get better looking images if you did.

This, for example, is exported out of LayOut.

You can see the full sized image here.

Another example here:

Thanks for your response. I did not try to export from layout as the edges were lines were jagged there as well. I just tested it and a .png is improved, but the jagged edges are still there.

For 2d export size from Sketchup , I tried “use view size” which was 1844 x 832, then 3000 x 1354 and finally 3688 x 1644 as that was double the view size. Ant- aliasing on or off produces same results.

I realize that this issue is probably related to my inexperience with this new graphics card. I will continue to experiment.

The Windows 11 print screen function produces a better image than Sketchup export so I will use that for now. When the settings are correct, can I expect the Sketchup 2d export or Layout export to be as the same quality as “print screen”?

Thanks for your time.

-Thom Huntington
Huntington Construction

Did you render the viewports in Hybrid or Vector? They would be jagged if you left them rendered as Raster.

I think it sounds more like inexperience with LayOut.

Are you getting the same kind of edge quality with your screenshots as I showed with my example images?

My edges are not like yours - because your drawings are awesome! I’m not there yet…

Quite right - inexperienced with Layout . Frustrated with it in the past, but trying again. I chose Vector in the Sketchup Model tab in Layout from a Sketchup file that has a single line drawn large wardrobe cabinet with no textures. Lines are improved but still not smooth like screen shot. Good enough for my use though.

However, I lost the text of my dimensions but not the slash marks when switching away from Raster. Do I need to make my workflow to include entering dimensions in Layout if I intend to render in Vector or Hybrid?

Thanks for your time,
-Thom Huntington
Huntington Construction

There’s nothing that I did that you can’t do.

Spend some time learning how to use LayOut at learn.sketchup.com

Add the dimensions in LayOut, not in SketchUp.

How do you intend to use these images once you have them?

An approach (“workaround”) to minimizing the jaggy aliasing artifacts is to export as a large image (say 6000 pixels wide or more), then scale down the image by 2x or 3x in an image editing tool such as Photoshop and let that tool interpolate the image pixels to make a smoother smaller image.

1 Like