How to export image with smooth edges?


#1

How to export image out with smooth edges ?
Currently my edges are sharp and it looks bad, check image


#2

What size is the exported image?


#3

Same effect on every size, tried to scale massive size and still saw edges


#4

You didn’t fill in any info in your forum profile, which forces us to guess what OS, hardware, and version of SU you are using. Please correct this so we can help you better!

@DaveR has already asked part of the key question: what options did you choose when you exported this image from SketchUp? The tiny text around the edges of the shot you uploaded looks like you have a high-dpi display and also like you have either exported a small size image from SU which is enlarged for the display, or have zoomed in close to a small part of the exported image. Most 2D exports from SketchUp are raster images. If you enlarge or zoom in enough on a raster image, the pixels of the raster become visible as the sort of “jaggies” you are seeing. In techno-speak, this effect is called “aliasing”.

Depending on the export format you chose, the exporter’s options may provide settings that will improve the appearance of the image. For example (all examples on my Mac - Windows may be slightly different):

  • all exporters provide one or another way to specify the pixel width and height of the exported image. Increasing the pixels will make them smaller relative to the features in the model.
  • jpeg, png, tif export additionally offer resolution and a check-box for Anti-alias

You could try exporting as a pdf. PDF is inherently scalable.

It’s also possible that changing SketchUp’s OpenGL anti-aliasing setting may improve the export. The availability of this preference setting and the choices depend on your OS, hardware, and SU version though. For example, SU 2017 on Mac does not allow you to change anti-aliasing.

Finally, you can always post-process the image in an image editor to smooth the edges. Like any anti-aliasing, this will cause them to look slightly blurry but that’s unavoidable.


#5

Thank you, now I got good image when exported as .PDF.
I guess I had resolution problem :slight_smile:


#6

This topic was automatically closed after 91 days. New replies are no longer allowed.