Jagged lines in PDF's


#1

Hi

When I export to PDF from sketchup I get these jagged lines, is there a program I can export to that won’t second guess what I’m doing and ruin the presentation?


#2

I would send the model to LayOut, render the viewports as Vector or Hybrid and export to PDF from there.

Screenshot from a PDF exported from LayOut:


Click on the Enlarge button see if at full size.


#3

@GraemeGRFinch those jaggies are “aliasing” caused by the raster resolution of your display.

Is your forum profile correct? Are you still running SketchUp 8 on an AMD FirePro V3900? What screen resolution are you using? You may be hitting limitations of that version and hardware.

Many of the 2D graphics exporters in SketchUp follow the notion that they should generate a wysiwyg image capture of the view, warts and all. When the screen shows aliasing, so do the 2D exports. It’s been a long time since I ran SketchUp 8, so I don’t remember whether its PDF exporter generates a vector PDF file or just embeds an image in the PDF (there’s a common misunderstanding that PDF is always vector, but that isn’t true. It is a document format that can embed images too). You might be able to reduce the aliasing by changing the options of the exporter, e.g. by increasing the output size and then scaling as necessary in whatever app you are using to show the PDF.

Failing that, @DaveR’s suggestion to go via vector or hybrid rendering in LayOut might work even better. Again, I don’t have SketchUp 8 at hand, so I can’t check just now.


#4

Thanks I’ll give it a go. :slight_smile:


#5

Thanks gents. I don’t think I’ll get sign off for new kit and software right now. I’ll have to find a work around.


#6

Your profile indicates you are using SketchUp Pro 8. If that’s the case, you have LayOut.