Layout Anti-aliasing in PDF export and in general

antialiasing

#1

Hey everyone,

This has been bugging me for a while, but is there any way to make Layout 2018 export/display smooth, non-jagged images? Exporting from Sketchup gives nice and smooth images, while Layout is always jagged…

Layout:

Sketchup (2x anti-aliasing)

Thanks!


#2

What are you using for render mode for the viewports in LayOut? Have you tried Hybrid?


#3

I could try that, but in my experience hybrid mode generally takes a very long time to process… But I can try it out. I have a newer computer which may help.


#4

While it will take a little longer to render, Hybrid rendering results in the edges being vector lines instead of raster images. That would be a solution to your complaint. You can try exporting at the High output setting with Raster render. It’ll probably be better but the lines being raster imagery will still be pixelated. Your choice.

Please complete your profile with Sketchup version and license type.


#5

I tried hybrid but it did take a very long time… It’s not practical for me. My guess about why the images are jagged is that it’s somehow tied to how the model views are snappable like the model, as if the rendered view in Layout is still active as a model in a way. It would be nice if when making a PDF or exporting it smooth out the pixels, since it doesn’t need to snap anymore, right?


#6

If setting Output Resolution to High doesn’t yield smooth enough lines, then you would need to render the edges as vector lines which is what Hybrid does. The fact is, as long as you insist on rendering the viewports as raster, the edges will be rasterized and won’t appear sharp like the vector lines do.

maybe you just need to turn off edges in the style you use for the scenes in SketchUp. Then it wouldn’t matter.

Maybe you’d get more acceptable results if you export PNG images of the pages and then insert them into a page editor to create the PDF.


#7

My issue/question is: Why can I export smooth/anti-aliased images from SketchUp, but the image output from Layout is jagged/aliased? (See attached images)


#8

What’s the Output Render setting? Are you exporting an image from LayOut?


#9

Layout render setting is ‘Medium’.


#10

Have you tried High?


#11

I have, but what I’m asking for is edge-smoothing/anti-aliasing. So, it seems like it doesn’t exist in Layout yet. That’s fine. Maybe that’s why there’s a delay in releasing SketchUp 2019…?