Sketchup crashing when importing CAD file

Hi! I’m trying to import a CAD (dwg/dxf) file to SU Pro and the system shuts down every time with this info box.
Screenshot 2024-07-08 at 15.41.47

I imported the same file a week and a half ago, saved it to SU and was able to open it fine. Today however, I’m also not able to open this saved SU file now without the system crashing.

I can see from other peoples enquiries that it’s likely to do with the CAD file, but I unfortunately don’t have the CAD program to be able to fix the issue there. Can I do anything when importing to resolve?

Any assistance gratefully received!

PERMIT DRAWINGS (6).DWG (6.5 MB)

I imported the dwg and got the same report as you showed. The model contents looked like this (with the imported group selected).

Typical of CAD files, the contents are scattered over some distance from the origin, but not hundreds of kilometers as often happens. Did you uncheck the import option to preserve origin?

So far it hasn’t crashed SketchUp, not on the original nor on closing and reopening.
Permit drawings (6).skp (76.1 KB)

Are you using the correct import unit? The file seems to be in meters. Is the “Preserve drawing origin” box checked or unchecked?

Yes, the preserve origin option is unchecked. I’ve just left the import unit as ‘model units’. So confused!

Is it really crashing or are you just getting the message “Not Responding”? If it really crashes are you getting a Bug Splat? And if so, are you sending in the report with your e-mail and name attached?

Sketchup just closes itself down and I get a ‘bugsplat’ error message. Then have to reopen SU

Yes, sending in Bugsplate with email

Are you sending the report with your name and e-mail address attached? If so, @colin could look up the report and help identify why it’s happening on your computer.

That would be amazing if someone could. I’m completely flummoxed.

A couple months ago, I started having problems importing DWG’s in SU2022 when they had always worked before. After disabling all plugins it worked, so I then spent the better part of two days trying to diagnose where the problem was with plugins to no avail. I eventually abandoned that installation and moved on to 2024 on a new machine, which was the long term plan anyway.

Another test is to use the web version of SU that comes with your pro subscription to import the DWG and save as a SU file.

Thanks. I’ll give this a try also

In the SketchUp system requirements it lists some GPUs that are not supported by the new graphics engine:

The following MacOS GPUs are unsupported:
Intel HD Graphics 5000
Intel HD Graphics 6000

I don’t know why that would show a problem when importing a DWG, but I can see in the 20 or so bugsplats you sent in (thanks for those!), that the crash is happening in the new graphics engine code.

Try choosing the classic graphics engine, in Settings, Graphics, and start a new document. Does the DWG import ok then?

Thanks Colin! And apologies for the many, many bugsplats (there’s nothing like repeating the same action and hoping for a different result (!)…) I’m heading out of the office now but will check when home this evening and cross fingers that this will work. Many thanks again for icing back to me!

Best,

Veta