DWG import problem

I have suddenly started to experience problems when trying to import a DWG file into SU.
After the file has been selected SU imports it and for a brief 0.5sec I can even see the imported file at Laura’s feet and the SU crashes out.
The same happens when I use SU2019 and even SU2018.
I am on SU2020, use Mac Catalina 10.15.5.
I have tried opening the DWG(s) in Adobe Illustrator and exporting as DWG (which usually works), with the same result. The DWG files themselves are ok as a. I have previously been able to open then in SU, b. I can view them in Illustrator/ Autodesk’s Viewer and other software.
It feels like a Mac issue as I can get the same experience in previous SU versions but any advice or insights would be appreciated

You might want to download the true view app from Autodesk and convert them to R14. Newer objects and proxies can be problematic.

Are you using the correct import unit (in import options)?
Can you post an example DWG (noting that this is a public forum)?

I set the import to model units (the alternatives are inches, feet, miles and with the survey and my SU units are metres.
I have attached a dwg that caused SU18,SU19 and SU20 to crash 005 06 20 Croft House, Two Mile Ash Road, Horsham RH13 0PG Rev A v2 2004.dwg (517.3 KB)

Works like a charm on my PC. Running Win10 Pro, SU 20.2.172 which I did NOT right-click to install as admin :wink:
Did not adjust units or anything, just File - Import selected your DWG file and clicked Import. The import units should NOT cause SU to crash. It would cause the file to be out of scale but can’t see it crashing SU itself. Well, it’d be a 1st in my time with SU (since v3).
Here is your file if this helps.Croft House.skp (4.4 MB)

Edit: It will need to be scaled, sorry.

I think it has happened sometimes when the units are too small.

1 Like

Ah got it. That might do it for sure. Good point.

Sean, thank you for the file

I have played with alternative units , and as noted there is no improvement. I have installed SU2020 on second machine, a PC/ laptop and it has no problems… back to thinking this is a Mac problem

1 Like

Glad to help :slight_smile:

Is there a layer with an ‘unusual‘ name?
Mac don’t like empty layer names, for instance.

1 Like

You can’t have an empty layer name in AutoCAD. All layers MUST have a name.

1 Like

You know what Mike, you did have a good idea to check to see if there were any weird layer names. I went back to look in the dwg and I didn’t see anything out of the norm.

Works ok as an import in SU 2020.2 on Mac Mojave 10.14.6.

I get some warnings on import.


Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

Layers: 52
Blocks: 5
Arcs: 608
Circles: 136
Ellipses: 4
Inserts: 604
Lines: 6356
Points: 1105
2d Poly-lines: 1214
2d Solids: 7
Splines: 226

AutoCAD Entities Simplified:

Coords out of range: 289

AutoCAD Entities Ignored:

M-Texts: 690
Texts: 449
Anonymous Blocks: 2

But no crash.

This is what I see after Zoom Extents

The dimensions of the bounding rectangle aren’t round numbers in either metric or feet and inches - I just accepted the default settings for a DWG import, so the scale may be wrong.

But here’s the SU file in case it’s any use to you. It’s nearly 10x larger in file size than the DWG.
005 06 20 Croft House, Two Mile Ash Road, Horsham RH13 0PG Rev A v2 2004.skp (4.4 MB)

1 Like

try this one:
Untitled.dwg (331,0 KB)

Looked the same on my Windows 10 Pro machine.

AutoCAD threw up an NLS error when I 1st opened the file but I hit “Yes” and it looks OK in CAD on my end. Every thing came in as a block on one layer. I was able to explode and then re-assign all items to “ByLayer” which did help.Acad NLS error

1 Like

Thank you I appreciate the time spent.
The file is not the problem as I can access it and all of the DWGs I need to use via a PC laptop, just no idea why SU has decided to crash after trying to import ANY DWG.