Problem opening DWG file

Have been having difficulty opening the attached file. When I import it SU manages to go through the whole conversion process but then reports that some elements are far from the origin. I can’t seem to find anything that is. What happens is that straight after the report, SU crashes.

Any ideas?

53 Garden.dwg (655.8 KB)

What units are you using to import with? If meters, it’ll be quite long. Even with units millimeters it covers a pretty good chunk of ground.

What units? Not sure. I think I just hit import. It’s all full scale stuff as usual with CAD. It’s only a fairly large area of garden, not most of Montana! But I guess you’re saying that I need to pay attention to a setting that helps SU know what it’s dealing with, right?

BTW, not sure what you uploaded as it’s just blank.

Click on options after you open the Import window.

Well, it couldn’t hurt. :wink:

Not sure why you are seeing a blank. It’s a screen grab of your DWG file after importing into SketchUp. Can you see the image I attached to this reply?

Maybe because I am on a Mac I don’t see what you do, Dave. When I hit Options, this is what I get:

11

I choose model units because I don’t want any of the imperial options. Both the drawing I am importing from and to are metric.

No, but for an ignoramus like me I figure that the default is that you will be working in real world dimensions as CAD only uses scales for output. So I don’t really understand why you need to tell SU what we in Britain would call the “bleedin’ obvious”! It seems a bit like getting in a car and having to remember to tell it that when you select a forward gear you want to approach the things you see and not recede from them by actually going in reverse!

All your images show up now, even the one I couldn’t see previously. Because the garden area is large, and the sections and elevations are all in line, it does end up covering nearly half a click, but that shouldn’t give SU too much of a headache should it?

Dave, as you seem to have been able to open the drawing in SU, is there any chance you could forward the SU file? It would be much appreciated.

Well, that’s odd. I’m not sure I ever noticed that metric units weren’t selectable options on my Mac.

But do you have units set to Millimeters, Centimeters, or Meters?

I think the issue is that while you might be working in one set of units, the CAD file could have been done in a different set of units. We see this all the time where imports are the wrong size because of the units mismatch. When the user sets the units to match the original file units, the problem goes away.

Not if it is imported with the correct units. If it was imported at meters, though, it’s a little bit different.

Here’s the file. I imported with units set to millimeters but I have the model units set to meters.
Simons Garden.skp (1.1 MB)

Simon, on my Mac I can’t duplicate what you are seeing. When I open the import options for dwg I see this:

And on importing the model there are no complaints about items far from the origin. I get this:

The imported model looks like this:

What model units do you have set? I tried both metric (meters) and Architectural and got the same results…

The template I import to is set to millimetres. The DWG file is one I drew many years back in Autocad and would also have been in millimetres because over here, that is the default for architectural drawing.

Good news is that I can import your SU file no problem. Thanks again Dave.

Funny thing is, I don’t normally have too much issue importing DWG files, whether they are old ones of mine or from elsewhere. Seems like it’s something to do with this particular file that is causing the problem. I don’t normally touch the Options button.

It’s odd that you and Steve are seeing different things in the Options panel, though.

At least you can keep moving now.

Steve, I think my last post to Dave probably says it all. I wonder what determines what is in the Units drop down box? If I had an imperial template loaded, I could understand it.

Hence my comment earlier about half a kilometre not being too testing for SU. I would conclude that the DWG file was corrupted but if both you and Dave can open in without issue, it surely can’t be that.

The last used import units are saved in the SharedPreferences.json file. But I wouldn’t think that should force the list of available choices in the options dropdown. I tried a few experiments with model units vs options and still couldn’t get what you saw.

Which update version of SketchUp 2019 are you using? I wonder if the dwg importer saw a patch for 2019.2 (I don’t remember)?

import_units

john

1 Like

So why doesn’t Simon get the scroll bar?

John, you nailed it! The scrollbar is not shown by default on the drop-down list, and if you don’t realize it is there, the choices @simoncbevans showed are off the top of the list. It seems that what you see is affected by what needs to be shown to repeat the units you used last time.
options%20scroll

I’m tempted to wonder “Why on Earth not??”. I will test this for myself when I can risk having SU crash on me again. But if I can make the scroll bar magically appear like you, that may at last solve the riddle.

I still wonder what SU uses to populate the scroll bar. If you have a template in millimetres, I would expect it either to default to that or at least limit things to metric options. But maybe there are weird situations when…

That is a bizarre way to have a drop down menu set up. Especially on a Mac where everything is supposed to be so intuitive and easy.

1 Like

it’s stored in the json file…

        "DWG Importer": {
            "ImportBreakEdges": false,
            "ImportMergeCoplanarFaces": false,
            "ImportOrientFaces": true,
            "ImportPreserveOrigin": false,
            "ImportUnits": 5

the scroll bars are an Apple thing as El Capitan shows them by default…

just use the scroll wheel on later os X’s…

john

Although I have plenty of native Mac software that shows scroll bars unhidden. Mail, for example (since I am looking at it open on my screen).

it’s specific to the drop down list type available in ‘interface builder’…

because they previously showed, the functionality ‘possibly’ now has a button to be toggled…

if so then SU could turn it on for the next version…

maybe, @slbaumgartner can be enticed to have a look, in my version of Xcode they are the default…

john