Issue importing DWG direct to Layout

mac

#1

I must be doing something wrong.

I downloaded a map in DWG format. Normally, I would import that into SU and then produce a LO drawing. But for speed and in the interests of keeping file numbers down, I tried a direct import. Importing was no problem but the scale is non-standard and if you try to dimension something, it is wildly wrong.

I didn’t see any import option for scale so the import process must create its own somehow.

You can change the scale but it still ain’t right. All my settings are for metric so I don’t think it can be the old metric-imperial fight.

Here is the LO file:

Temp.layout (39.2 KB)


#2

What scale do you want it to be displayed at?

Can you share the DWG file?


#3

Dave, you’re so quick!

Probable scale would be 1:1250.

Here is the DWG I bought online from mapping specialists:

Toppers-The-Terrace-Aldeburgh-Suffolk-IP15-5HJ (1).dwg (142.1 KB)

The grid represents 25m squares (or should!). I suspect it doesn’t and that that is where the problem lies.


#4

I wonder how that file was created. It imports into SketchUp just fine other than being almost 700 meters from the origin.

I wonder if @trent could take a look at this and tell us what we’re missing.


#5

I have no idea how it was created and, being an online source, I probably wouldn’t be able to find out. If I did get an answer, I probably wouldn’t understand it!

Since I first posted, I too imported it without problem to SU, but for me it came in as normal as a group that I could set at the drawing origin.

It didn’t import at real world size so I had to re-size it. I think that is the source of the problem.


#6

Did you set the scale before importing it? I set it to Meters and it came in full size.


#7

No, I saw no option to do that. When I select the DWG file for import, I get the dialog box below:

00

The default option is Paper Space but that produces no result. So you have to select Model Space. Then it just comes in at whatever scale it has set itself to.

Have I missed a step?


#8

I was talking about setting the scale when importing into SketchUp.


#9

Oh, sorry. No, I just imported it expecting it to bring it in at full scale. I just tried the other way. You are not actually given a choice of scale so much as units. I chose mm and what should have been 10m became 10mm. I guess I should have chosen metres.

However, this is all a bit academic because I can deal with things I import into SU first. There is another advantage of importing into LO besides the ones already mentioned. You get a lot of text that SU strips out, so it looks more like the DWG file it is based on. So do you have any idea why LO mucks up the scale?


#10

I was hoping I’d see something that was getting missed but I didn’t. That’s why I pinged Trent.


#11

OK. The fact that it puzzles you too reassures me that I haven’t just done something daft!


#12

I’m not sure that should be reassuring. Could be we’re both doing something daft. :smiley:


#13

That’s very humble of you, Dave, but the stats suggest it is way more likely to be me!


#14

Could this have something to do with it?


#15

That could very well have something to do with it. Good find.

So can the file be opened in ACAD and possibly fixed to satisfy the requirements for LO?


#16

Curiouser and curiouser.

I remember now an odd thing about OS extracts. Even when opened as DWGs, the scale is wrong by a factor of 1000. That is easily corrected. But when I open the corrected version in LO I get a default scale of 1:18816! The physical size of the import in relation to page size does not vary but the reported scale is all over the shop!


#17

Here is a screenshot of the DWG file. Although it is in Model Space, the OS works in metres so when you measure something that is 10,000mm, it reports it as 10.0. Architects tend to work in mm not metres, so if I drew something on the DWG drawing that was 1,000mm long it would actually draw something 1,000m long. So it’s all a question of units. I have to scale the OS extract up by 1,000 to be able to draw normally.

Still, how you get a peculiar scale like 1:18816 in Layout from this is anyone’s guess!