Insert dwg into layout 2018

Hi, Im having trouble with inserting .dwg into layout 2018.
Whenever I try to insert the paper space, I get nothing. Zilch.
Only if I select model space do I get an import. and when trying to set the scale I am only offered scales in Imperial, no metric scales - my template is set to mm and the scales are in the list in the preferences, so I should see them right?

Any ideas?
Ive tried dwg’s from a number of sources but only ever get an import from the model space.


How do you know the files you tried contain objects in the Paper space?

As to scale, LayOut imports files using units embedded in the AutoCad file. Units in your LayOut file don’t influence the process.

Hey, You are right I don’t. Good point!

As to scale, dwg is in mm with annotations in mm with a stated scale of 1:10.
If I open the dwg in autodesk viewr 360 it measures in mm.
In the list of scales I only see imperial scales, yet if I add a custom scale it displays the custom (metric) scale. I thought layout should behave agnostically in terms of the ‘make scaled drawing’ scale you use.

I have exactly the same issue - importing a file to my Mac exported from Archicad (Mac) as a dwg. Paper space opens blank. Model space is swamped by massive arrow ends and has only imperial scales, despite it being exported in millimetres. Unable to do anything to the page and had to force quit the program. I’m trialling Layout 2018 but this is looking pretty hopeless at this point.

Did you export it yourself from Archicad? What kind of export settings were used? Is it a 2D or 3D export? Can you post an example file that displays these symptoms?
I am rather suspicious of DWGs exported from Archicad, even those I export myself. It is extremely important how you set up the exporter.

No, the file came from a colleague - I think it’s a 2D, although I know some of the project had been done in 3D (I’ll find out). I can put up an example tomorrow. If I can have some info on how to ask for the export that would be really useful.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.