Importing DWG into Layout

I must be doing something wrong.

I am trying to import a DWG drawing directly into LO. Because I want it to look like the drawing does in Autocad, I choose to import paperspace items. But nothing happens. These are the default settings:


And this is the drawing I am trying to import: Silt_Trap_6LB600__Extension_Option_A15__D400_Loading.dwg (128.4 KB)

What am I doing wrong? Could it be the DWG version? It loads into SU OK.

The “Paper space” in the drawing is totally empty - that is why you don’t get anything into LayOut with the Paperspace option.

1 Like

That would explain it. But if everything is in Model Space, why do some things, like text, not import when you use just the Model Space import option?

Text and Dimensions should come in as long as you import as native LayOut entities. If you have the model space info coming in as a SketchUp model ref, SketchUp does not support these types.


This is what I got after importing with the Model Space (only) option. I had to correct some of the font sizes, they came in at an enormous size:

I must try again if it’s just a question of changing font size. Thanks.

I attach a newer version that I got when importing the file with Millimeters as the unit and then set the resulting Scaled Drawing to Full scale. @trent, what’s up with the text sizes? Some get imported at ridiculous sizes and grossly outsized bounding boxes, while everything looks perfectly normal in Autodesk TrueView.
Untitled2.layout (142.8 KB)

We are aware of this problem and are working on ways to solve. When importing a file that contains text in the Model Space, LayOut brings everything in 1:1 places it in a Scaled Drawing based on user paper size. When it does this, text can inadvertently retain the model space height and will display in incorrectly in LayOut (paper space)

One way to fix majority of the text is to create text at the desired scale off to side, select the eyedropper (style) and apply it to the entire Scaled Drawing. This will minimize the clean up.


1 Like

What I noticed was that the misbehaving text objects were listed as “blocks” in TrueView, and their scaling was non-uniform. The purpose was perhaps to achieve a condensed effect.