Problem importing DWG

dwg
import
mac

#1

Can anyone help with this problem. I have seen it before but cannot remember if there was a fix.

A drawing was sent to me as a DWG, though I am not sure it was created in AutoCad. If you open it in AutoCad it looks fine. But when you import it into SU, almost all the detail is missing. I have tried saving it as a AC2010 file but it makes no difference.

Is it possible that the original file has been locked in some cunning way?

Here is the file: NONAME_0.dwg (121.7 KB)


#2

I have no expertise at DWG so someone else may offer more insight, but I also had a bad import of this file. Here’s what the import reported, and how the model looked:

Versus what eDrawings shows:


#3

Hello, @simoncbevans !
Explode all the groups from Autocad (DraftSight), save as dwg 2000, and I think that’s it!
That seemed to be the solution from another discussion.


#4

Here you go,
I opend the dwg with pcon planner, cleaned the file, exported to .skp, opend it in Sketchup
The file is to big to upload
You can downloud it from my drive
https://drive.google.com/file/d/1U9NZdBVTPBOv-520DJk42RhT-uVboRLS/view?usp=sharing


#5

Oh, no! There are zombies it that file! :scream:

(OK, what’s a zombie?)


#6

Autodesk has Zombies:


#7

Yes, that is exactly what I was getting too.


#8

Wow, thanks a bunch, that’s exactly what I was after. I don’t have Pcon Planner and I think it may be a Windows program which I cannot use. Any idea what Pcon does that Sketchup can’t?


#9

I will have a go with your suggestion as I do have other drawings from the same source that I may need to import.


#10

This works, even without saving as an earlier version of DWG. Such a simple solution in the end!

However, it begs an interesting question. Is SU unable to import DWG blocks? Or is it something specific about the blocks in my DWG file that makes it fall over?


#11

Salut, @simoncbevans!
I tested it with pcon.planner and it’s working just fine. I told you to save in dwg2000 just in case.
I don’t know what kind of problem SketchUp has with dwg blocks.

Any idea what Pcon does that Sketchup can’t?

Versus SketchUp Make, has the possibility of import/export dwg, obj, fbx, etc, it’s free for commerical work, and versus all version of SketchUp, has native render inside.


#12

This article does not refer to blocks as such but does say that Nested Blocks can be imported. Blocks do not appear under unsupported items. It does go on to say that unsupported items should be exploded, which is exactly the solution found.


#13

Because I usually work directly in SketchUp, or over a picture, and SUMake does not have dwg import, I have not carefully tracked such details. But as a general idea, SU tips I try to follow them in tutorials or discussions.


#14

Maybe they are not blocks in fact but Proprietary ADT Objects, which are unsupported.

I wish I could use Pcon Planner though as @Bep’s model managed to import every detail of the DWG file including text and dims. SU doesn’t do that natively.


#16

I didn’t get involved as I’m using Windows. But just to throw a spanner in the works, your file came straight in completely with no problems. Why, I have no idea.


#17

Right, so this may just a Mac/DWG/SU issue, perhaps?


#18

I went straight in and did some exploding and made a save as, that went in fine. So, I tried the original and that worked too!
I re-downloaded and tried the vanilla file another 2/3 times just to make sure and it worked every time.
But, yes the only thing I think of is a Windows/Mac thing. Unless I just ended up with a better version of SU than everyone else!


#19

Steve, I see that you are also on a Mac and I think that is relevant. You can reproduce my issues exactly, whereas those on PCs seem to have little or no difficulty.

Following advice here, I downloaded Pcon Planner to my Windows laptop and tried using that to convert prior to importing back into SU. It certainly makes a better fist of things but it is a long way short of what @Bep was able to do.

Do you think this is an issue that is known at SU HQ? If not, should they be alerted?


#20

Ok, I’m on a Mac, and you’ve got me curious. I get the same results in SU Pro 2018.

I tried opening it with PowerCADD and it seems to open OK.

It’s just 2D, right?


#21

The staff generally scan the forum so we can hope they see this. It’s odd that there would be such a difference between Windows and Mac because I would think the heart of the importer is platform-independent C code - but I have no insider access so that’s just a puzzled reaction.