Problem importing DWG

dwg
import
mac

#22

I just imported it on my PC and got a warning as below. But after clicking Close, I got the following.
Screenshot%20-%208_4_2018%20%2C%2011_08_16%20AM


#23

I think that’s relevant, as on my Mac I get a warning about points too far from the origin being deleted.


#24

One thing is the “Anonymous blocks”. SketchUp cannot import them. AutoCad creates these in some situations, for instance, the instances of “Dynamic blocks” and some hatch and surface objects are anonymous blocks. Some third-party add-ons also create them. If you are able to explode them before importing into SketchUp, you might get better results. Often AutoCad, however, refuses to explode them.


#25

I do but still not as good as Bep’s efforts, and other PC users here.


#26

Yes. And there is no problem opening the file in DWG based software AFAIK. The problem seems to be in the conversion process, and more specifically with Macs.


#27

There are real bugs importing dwg or dxf into Sketchup.

The most common is scale, where I believe I tried everything either on Mac or Window, it never match what ever export parameter you use… On square object, it’s always possible to manage with the scale tool, but, for example a pentagone, forget it unless you have time to loose…
Scalebug
I notice that depending of the graphic fill, things can go really bizerk. So I tried to explode everything and import simple lines…
Before cleaning dwg/dxf bug (scale + bizerk things)


No way, bugs remain after cleaning dwg/dxf (scale + bizerk things but not as bad)

After 2 hours of work getting the object to correct scale with a base print to work on 3D modelling

Then 2h only to do the basic 3D modelling based on the print

Unfortunately, you should not count on being able to do “non square” objects quickly with Sketchup, as the name say “sketch” and not “produce”.
I thought at first I could “do any print precisely” on a 2D program that can generate dwg or dxf files, but I was wrong. Even simple objects like this…

…you will get bugs
And worst when you get into 3D modelling with objects you have cleaned…
LinesalloverBugs
…to get what you want like this

Now, on both platform, if I start from beginning with Sketchup, I don’t have much to complaint, it’s ok, but as soon I import anything, am facing endless bugs.

For me, the best is to develop on a 2D program and “repeat” the information obtained (after managing the object into a concret need) in Sketchup.

However, we should not complain about Sketchup as the licence price is at the hight of what it offers. It is possible to do beautiful things with it, but forget to try to be a professional architect or builder or inventor, as it is not suited to do so. If it is your profession, then get into Revit or Archicad, but the price is not the same, there are no miracles…


#28

Do not use scale, use the Tape measurements tool, enter the imported .dxf component and click the endpoints of a known line (edge). then type the lenght you want it to be:

Place the axes on strategic lines for working ‘square’

At least you could share the Bug4simplethings?

After all, it is called Sketch…Up, not Down :joy:


#29

The function don’t work from 0.09 to 3.6m neither from 0.09 to 0.10m it just disappear and no way to get it back

But I got it to work using scale to approximative, but a little bigger size (3.83m), than used the tape measure to get it down to 3.6m

To figure this out it took me almost 2 hours : a bunch of modifying the dwg (all surface to line, all lines the same, and so on) - cleaning the first component to something looking flat - then trying all sorts of different approach…

I got it the way I wanted but it’s very frustrating not to be able to import a flat drawing in good scale at first and then having to deal with bugs

Sorry, I don’t have time to redo all the work to send you Bug4simplethings, it would take me too much time, time I don’t have…

Thank for you answer, at last I got to have the object the correct size

Edgar Schnegg

Av. de Crozet 6

CH-1219 Châtelaine

Portable : 079 445 05 21

www.schnegg-e.com


#30

If you would share a simple .dxf, as requested to ya in other threads as well, then others could have a look and try to reproduce the errors/difficulties you are experiencing (one of the main conditions for it to be a Bug), you could then save a bunch of time…

It could be a rare occasion of a PICNIC, instead of a real bug.


#31

The answer is clear, working day and night, I don’t have time to find the file and go thru all the processing before I can send you something to repeat the expérience.

Beside, not being alone, I am under the condition of duty of discretion. I can’t spread any confidential informations.

However, I send you an attached :

  • Old jpg done with AutoCad 2010 without stairs made in an other file

  • New pdf done with Sketchup 2018 including the stairs for witch I imported 2 files

With this information:

  • I did this 3D work on Autocad 2010 or 2011 in 2013

  • I could not import any file in Sketchup v.2016

  • I downloaded Sketchup 2018 for a try and promised myself to upgrade to v.2018 in case it would do the import

  • I don’t remember how many tries I had to go thru but it did succeed with the import in v.2018

  • I upgraded to v.2018

This is not confidential information, so I can share with you this information.

As you noticed all pictures I send you does not permit to identify the concept.

By the way, a pentagone is not an hexagone (in the example you gave me) thus making it simpler to make an example ;o)

Edgar Schnegg

Av. de Crozet 6

CH-1219 Châtelaine

Portable : 079 445 05 21

www.schnegg-e.com

100806 La 6x6.pdf (360 KB)


#32

Et si vous enlevez les titres…?

En generale, ce n’est pas difficile d’emporter un dessin de type DWG avec Sketchup.

Mais enfin, tout le monde s’embete de temps en temps!


#33

Meet Sam Carpenter


#34

Ce qui est confidentiel est la technologie, c’est toujours facile d’enlever des noms, mais il y a des concepts non propriétaires qui ne peuvent se divulger jusqu’à qu’il soient protégés en matière de propriété intellectuelle et de marque…

Mais ce que personne ne semble comprendre est le paramètre temps. J’ai passé des heures à trouver le moyen de contourner les bugs auquel j’ai été confronté, cela a résulté en dizaines de fichiers et JE N’AI PAS LE TEMPS de 1) de tout re-tester retrouver le premier 2) de faire tous les exercices pour sortir une chronologie 3) de modifier le concept afin de le garder hors de portée de la concurrence…

Dorénavant, je fais attention au paramètre “transmettre le bug” 1) parce que j’ai “déjà trop perdu de temps” 2) parce que je le sais utile et ne vous inquiétez pas, je vais tous les soumettre à votre expertise afin de contribuer, tant que je peux, à la résolution des bugs.

J’espère que cette explication sera suffisante, merci de ne plus insister

Edgar Schnegg

Av. de Crozet 6

CH-1219 Châtelaine

Portable : 079 445 05 21

www.schnegg-e.com


#35

my bad, but it is actually the same procedure…
besides the manually ‘Place’ there is also an option ‘Move’ which give you that ‘Autodesk’-feel: