Dwg import issue

Hi, every time I try and import a certain dwg it creates a bugsplat. Is there something in AutoCad I need to turn on or off to ensure I can import the file?

Thank you!

You don’t say if you are importing into SU or LO.

How big is the DWG file and what version of AC?

Sorry! I’m importing into Sketchup 2019 Pro the .dwg file is around 6mb but varies as I’ve tried exporting it as various versions and ages of AutoCad.

Is it a “plain vanilla” AutoCad file or has it objects like AutoCad Architecture walls in it?
Is the AutoCad geometry very far from the origin point?

I would say vanilla, maybe with sprinkles on as it is quite an involved plan. But I can import this contractors plans normally, which is the odd thing.

I suggest to isolate needed Layers in AutoCAD and copy into new file.

Could I ask one of you try it, as I have done all the suggested options. Maybe you’ll have better luck?
Model 2020-01-24 RG.dwg (3.3 MB)

  1. Tried to import Your files without any modifications and SketchUp crashed
  2. Tried to copy plans (with rectangle boundaries) into new file
  3. Purged new file
  4. Imported new dwg into SketchUp (without any problems)
  5. Make sure during the import to choose right units and untick prevers drawing origin.
    import.skp (2.3 MB)

Amazing. That’s awesome. There must have been something in a layer that it didn’t like. Thanks for the tip on purging.

The drawing has a lot of hidden layers, with many other lines, texts and dimensions.

I know. I’ve even tried purging but it is still making a bug splat. RG2.dwg (969.6 KB)

If you follow @robertjuch’s instructions
RG3.skp (3.6 MB) (check the units!)

hmmm I have followed @robertjuch instructions but it wouldn’t import for me. What units are you importing it as? Thank you though everyone, I REALLY REALLY appreciate it.

I assumed there are millimeters.

Yeah, tried that. What you have done is great. I’m just worried moving forward if I have this issue. I need to move files in and out of sketch/autocad and never come across this.

  1. Try to copy this into new file:
    copy this
  2. Use command “purge” and select “purge all”
  3. Save as “autocad 2000”
  4. Try to import

Nope. Still doesn’t work for me. I’ve followed this exactly and it still causes a crash. Thank you for attempting to help me though.

Are there clipped xrefs, blocks in the autocad file?

not entirely sure how to check. I’m not a master at either CAD options TBH. Happy for you to have a look though?

ok no
Noticed that I draw wrong part, and tried to import once more.

So this blue part causing the problem, and red part is ok.