DWG import issues

dwg
import
bug

#1

Hello, I have many problems importing DWG files. I am aware that most of the time, sketchup is not the one responsible, and that it’s rather the drawing itself that has small gaps, or different Z parameters.

Not this time.

First I had problem with blocks inside blocks that were shown miles away from the drawing. I had to explode them inside autocad so that it could be imported properly. Ok not a big deal, but it adds 5 minutes work.

Then, I have this :

The problem is very common to me (and many users I guess) and where usually a quick close gaps, line extend and intersect (for the reasons I listed above) would do the trick, this time impossible to close the areas unless I redraw most of it. Not so long you will say, but if it happens on every project… it will get on my nerves !

Here’s the file if you want to try yourself
c.skp (2.9 MB)

While I’m at it, talking about bugs… Am I the only one who experienced strange results when intersecting simple geometries ? very often I end up with useless hidden triangulation of my walls, that I have to reveal and then erase… I don’t have an example right now, but next time it happens I’ll post an example file…

Thank you for reading

Paul


Welcome to our forums! Please introduce yourself :)
#2

The linework is so full of minuscule errors that I don’t think it is reasonable to expect SketchUp to perform miracles. The face finder gets confused when encountering all those intersecting and double lines. Is the original auto-traced from scanned raster images?


#3

Hello and thank you for the answer.
It comes from a pdf that i exported from illustrator. I had no other
choice :slight_smile: so i’m aware of the multiple lines, and i’m not talking about the
walls, only the center of the plane I made, which has to become the
bleachers (enter the groups till you see what’s on my screenshot) . These
are polylines i drew myself in autocad


#4

Oh boy, sometimes if feels like I spend half my time cleaning up .DWG files of theaters just like this one, the other half I spend on this forum. :face_with_raised_eyebrow: It’s amazing I get anything done at all.

Yeah this line collection is something of a mess, I see it all the time. Lots of doubled lines, tiny missing lines and some vague Z dimension drifting. Many of the faces currently made within the wall cavities are reversed as well.

There is no silver bullet that I have found, it still takes me time, but sometimes I have luck:

Exploding line collections, copy pasting and re-componenting in a separate file.

One common workflow for me is to select the whole ground plane of lines, explode it, with all selected run Fredoscale and scale in the blue Z AXIS with a value of 0 (forces flattening). Then in the same context draw a large rectangle around the floor plan in the same plane, skinning all surfaces together with the same orientation, then erase outer rectangle and any unwanted faces and make component.

For this seating area floor I think i would just redraw the planes, or option move the down house line toward the back of the house multiple times then trim the edges, in any case I would erase the existing darker profile lines and draw again in sketchup. The darker profile lines are for some reason not drawn on that surface plane, although they appear to be. couple of of the Z values I pulled read -0.00 and others just read 0. might be ACAD variance smaller than sketchup minimum? But import should have resolved that, or maybe not. As I said, this is always an imperfect process for me too.


#5

In the past I have spent just as long in illustrator re-drawing or editing blueprints and files as I spend making the model. I did a job several months ago spending about 4 days of a 5 day job tidying things in illustrator alone.


#6

There shouldn’t be any Z drifting at all, since it’s been exported from a PDF… What’s more is that I ran a flatten selection from ThomThom’s architect tools plugin.(faster than the method using fredoscale). Usually it works, sometimes going through an intersect after closing gaps as well. This time it didn’t that’s why I decided to post the file.

Anyway… I guess we’ll have to deal with it !


#7

I’m sure you are right it must be flat, I was curious about seeing both 0 and -0 listed as the Z dimension but it’s probubly just a quirk of the process. -0 is quite a concept. Yes even with all these tricks I see odd behavior like in your file quite often, I guess we do have to live with it.


#8

other bug today… I had to do this :

and when I imported the .dwg and wanted to rotate the section this happened :

I simply selected my section (note that I selected from top left corner, so nothing else is selected) and rotated it 90 degrees and grouped it. I know I should have grouped it first, but still, is this really supposed to happen ?

I don’t have any previous version of sketchup here, so I don’t know if it’s only sketchup pro 2018.

Here’s the file

TR.skp (257.9 KB)


#9

:face_with_raised_eyebrow: Yup, I do that operation with imported .dwg in SU all the time, and have never seen that. What wrote the .dwg file? Was it ACAD itself, or some other software, like Illustrator?


#10

autocad itself, I drew everything in it with polylines and circles (very quickly I must admit)


#11

Ok, I tried the same operation on your file and didn’t get same results.


MacOS X here and SUPro2018. Different set of plugins, if that matters some how.

The origin of the group is 1500m away for whatever reason.


#12

It worked OK here as well.


#13

It Happens when I group the current selection right after rotation, on your screenshot it doesn’t seem to be grouped…yet.

True, my origin is a bit far, but not far enough to cause any troubles, I believe.
I even retried after replacing the origin, it is still giving me strange results :

Thanks anyway to you two for trying to reproduce !


#14

Before starting modeling You should move imported component to the origin. Than explode the component (because he is defined far from the origin). And only than make separate groups (plan and section) and rotate them.


#15

Ok, yes I reproduced it as you described by immediately grouping what’s still selected. It doesn’t look like everything originally selected still is, however. If I deselect all and draw another selection rectangle around it and then group, it doesn’t happen. It is strange.


Deselect and reselect:


#16

In my experience, clipping starts to be annoying at around these distances


#17

Hello Robert,

I know I should have done that (as I said before), and that’s what I usually do, but I’m simply pointing at something strange occuring !


#18

Yes @RTCool ! That’s exactly what I get, some elements seem not to be selected anymore, and if I reselect them before grouping it works fine.


#19

Many of this strange things You can recreate making geometry far from origin in Autocad. And than import these files to Sketchup.


#20

Yes, there are elements that are clearly operated on by the rotation, and yet they aren’t still selected afterwards and don’t get included in the group.