Importing DWG Sketchup 2019

I have posted here recently about a problem I have had importing DWG files into SU recently.

I attach a very simple DWG file that exhibits the same issue. If I try importing into SU 2019, everything looks normal, right up to showing the imported drawing (very briefly) before it crashes SU.

Just for a wheeze, I thought I’d try doing the same thing with an earlier version of SU. I used SU 2016. That has no problem importing the file. Interestingly, the report is slightly different between the two versions.

I guess I have just found myself a workaround. Is it odd that an earlier version of SU imports a DWG of even earlier date but the current version can’t do it - or at least, not for me?

Here’s the “rogue” file: Hoxne.dwg (252.1 KB)

Of course I get the usual crash report and dutifully send it on, but it’s the usual one of “Sorry, bud, but now move right along.” Presumably not a recognized issue.

No problems for SU2019
2019_dwg
Hoxne2019.skp (343.5 KB)

Exactly what happened last time. Others with SU2019 can open the file but I can’t. Could it be related to the fact that you use a PC and I use a Mac?

If there are no more reports of this problem from other SU2019 users in Mac, maybe another cause should be sought.

I can import it on my Mac without any issues. Seems to be something specific to your computer or perhaps the extensions you have loaded in SketchUp.

It hadn’t occurred to me that extensions might affect the basic working mechanisms of SU. Is that truly a possibility? It would make me think hard about installing new extensions.

Fair point.

There are extensions that use Observers to swing into action in the background every time you do anything to the model. They don’t “affect the basic working mechanisms of SU” per-se, but they attempt follow-up actions that may crash SketchUp. The Trimble team can tell from the BugSplat report whether the crash was triggered by a misbehaving extension, though it is usually not possible to determine which one is guilty. If you PM me a crash report I may be able to offer some insight about why SU is crashing (though not having access to the SU source, it will be subject to guesswork).

@simoncbevans

Do you happen to have the Layers Organizer extension installed?
With this extension active, I see the dwg import crash as well… but with the extension deactivated, the dwg imports successfully without the crash

CD

2 Likes

It also fails to upload in Trimble Connect.
The picture @mihai.s showed 6 layers imported, but there are not any in SketchUp.
We do see import-dwg-failures on Mac when a Layer is called ‘0’ in the dwg

I meant you, @simoncbevans :slight_smile:


I do. And it wasn’t installed in my SU 2016 plugins folder so you may have pinpointed the problem. Should the developer be made aware of this issue?

How do I retrieve it? This is what the standard response says and does give a reference.

31

@ChrisDizon may have solved it though.

Crash reports are located at

~/Library/Logs/DiagnosticReports/

Ones relayed by BugSplat will have extension .bugsplat.log. Ones captured by macOS will have extension .crash. Since BugSplat just packages and relays the macOS report, there will often be one of each for the same crash. But when a crash happens without BugSplat catching it (which occurs if the app traps an error and aborts itself) there will be just a .crash. The report names contain the app and date/time of the crash.

Have tried PMing you but I’m told I cannot upload files of that type. Is there a workaround?

zip it and upload that.

Just for the record, I deleted Layers Organizer, closed and re-opened SU 2019 and hey presto, problem gone. I can now import the DWG like everyone else.

As I don’t use the extension that much (though I wish similar functionality were built into SU), the obvious answer is to live without it.

Thanks to @ChrisDizon for the fix.

For the record, @simoncbevans PM’d me the crash report and it was definitely in a Ruby extension. So @ChrisDizon’s fix is right on the money.

Really? That would mean every DWG file in the world. Just like in SketchUp, Layer 0 is the “default” layer in AutoCad and cannot be deleted.

We have reached out to the developer about the issue

2 Likes