Sketchup and Layout 21 won't open. Get BugSplat

After rebooting my pc last night, I can no longer open Sketchup or Layout 21. If I just try to open the program from Startup I get a BugSplat popup. Same for Layout.

I then tried double-clicking on *.skp or *.layout files in Windows Explorer to launch the program with that particular file. Still get the BugSplat popup shown in 1st screenshot.

The BugSplat popup for Sketchup had a view details button, but nothing happens if I try to click it. The same popup for Layout (2nd screenshot) DOES let me click the view details button. That brought up the 3rd screenshot below

Did some searching for BugSplat on community, but couldn’t find anything recent, relevant or useful.

Is there a way I can see logs or other info to try and fix this?

I clicked Send on both the BugSplat windows and included my name and email. Does that automatically open a ticket or do I need to do that separately?

I also tried going to Technical Support section to send support a message, but it requires a BugSplat ID. Where do I get that?

Has anyone had this happen? If it was fixed, can you tell me how?

Thanks



2021-03-08 08_22_16

@colin or other SketchUp Team members can look up your crash reports if you have sent them and included your e-mail.

You say that the problem appeared after rebooting. Were there any Windows updates involved? The first thing you could try is to go to the Nvidia website and download and install the latest update for your graphics card driver. Windows updates have a track record of breaking them.

Does someone from support (@colin maybe?) automatically reach out to me if I included my email address?

I don’t think there was an update. It had just been a few days since I rebooted.

I’ll check out the graphics card driver updates.

Thanks

You might try a repair of Sketchup. Find the installer file, right click on it and choose the repair option.

Sadly, no, we don’t reach out for every bugsplat report, but if you contacted support you would quote the number. The bugsplat number is shown in a web page after you submit the bugsplat. I wasn’t able to find any reports from you.

I think that you have an EDU subscription, and you would normally contact Creation Engine to get help, and they would contact us if they didn’t know the answer.

As you have an EDU Studio subscription you could try using SketchUp 2021, and see if that has the same problem.

I kind of suspected you wouldn’t be reaching out to every report. :slight_smile:

I didn’t really notice the number the first times, but I recreated the issue again and noted the number: #36907.

NOTE - one of the replies suggested doing a Repair so I did that. It said the repair was successful, but I still got the same result. BugSplat #36907 was generated AFTER the Repair.

You’re correct that I purchased this with a student discount (another perk of being retired: can take college credits for free AND get student discounts on software, etc.). However, it says it’s a Sketchup Pro version. Are you saying there is a separate EDU version?

You also mention that I would “normally contact Creation Engine.” I didn’t know there was a separate support channel for software purchased with a student discount?

Thanks for any help!

All student versions in the US are sold through Creation Engine. It is the same software, except you pay $55 instead of $1199. It does include all that comes with SketchUp Pro, but also has Sefaira.

I see from the bugsplat that you are using SketchUp 2021 already, you should update your profile. It also looks like you have an Nvidia GPU, but that SketchUp is using the Intel GPU. Check to see if that is the case, and switch to using Nvidia if you can.

That is done in the Nvidia control panel 3D applications section. Automatic selection tends to favour integrated graphics.

Thanks for the reminder. I’ll update my profile.

I changed the graphics processor for Sketchup to use the High-performance NVIDIA processor instead of Auto-Select.

Got the bugsplat again. It’s Crash #37151.

Thanks @Anssi. It would have taken me a while to figure out where exactly to do that and what to change it to.

Unfortunately, changing to the “High-performance NVIDIA processor” for the Sketchup program didn’t fix it. I’m definitely going to remember this because it might help me with some other programs.

How many screens are you running, and does the crash happen before the welcome screen appears, or after the welcome screen and before you see a new model window settle down?

Try the Checkup application, and see if that gives any useful information:

https://help.sketchup.com/en/sketchup-checkup

Thanks everyone for the responses.

I have been using 2 monitors since before I got Sketchup and never had this problem until about a week ago. Tried changing just Sketchup to always use the nvidia accelerator with no impact. Then I tried changing the global default to use the nvidia accelerator and still didn’t fix the issue.

As it happens, my daughter came to stay with us for a few weeks and her monitor broke. So I gave her one of mine. Guess what? Reflexively tried Sketchup again and this time it worked.

I’ll leave this “unsolved” for now and come back and update it after I get my monitor back and try some other things.

Thanks again.

Are you connecting the external monitor directly to your laptop or do you have some kind of external “dock”?
Did you try the Nvidia driver update?

No dock. One connects thru USB and other thru HDMI.

All the drivers on Nvidia support page for my processor are dated a year before I bought the laptop so I didn’t bother. Surprised there haven’t been any updates for so long.

This is what the Nvidia driver search page showed for me when I searched for your graphics card model:
image

Hi Everyone !

Something new about your problem ? do you have found a solution ?

Today i’ve got the same problem …

Following Windows Update and Nvidia Update … Bugsplat

I’ve shutdown my dock (and one screen that was plugged in)
Now i’ve just one screen connected with HDMI to my laptop … and it works …

What do you think about it ? where is the problem (for sketchup) ? Windows ? Nvidia ? or the dock ?
I know i’ve got a probleme with the dock (that’s why One of my screen is connected to my laptop) and my second to the Dock

Strange …
BR
David

No, I haven’t found a solution yet. I’m a little further along. At least Sketchup opens now, but when I open an existing model I don’t see anything in the “model” pane. I see all the different panes like Default Tray and the vertical tool bar as well as the menus and the horizontal tool bar.

When I create a new model I don’t see any of the axes and nothing I try to draw actually shows up on the screen. For example, if I select the rectangle tool and start drawing it I don’t actually see anything.

Oh, I also noticed that the default units of measurements are metric instead of imperial as I had set a while ago.

Since I originally posted this, I have downloaded the latest driver from nVidia and installed it as an Administrator. I’ve also switched the input cords between the two monitors. One is thru an HDMI cord and another thru a USB. Lastly, I’ve made sure that PC is up-to-date on Windows updates.

I’m stuck. Anyone have more suggestions?

Thanks.

The seeing the tools both nothing in the modeling area, is the symptom that would happen if you had a less capable GPU, and had Use fast feedback turned on. You could check to make sure what GPU is being used, or just try unchecking the use fast feedback box in Preferences, OpenGL, to see if things then appear.

Same problem happening here. I’m using a Pluggable USB 3.0 docking station with two external monitors. Never had an issue before, now I get a bugsplat before SU or LO even open. If I turn off just one monitor, SU and LO will open fine, then I am able to turn the monitor back on. Not the end of the world, but very annoying.

Probably an issue with the driver for the docking station. Many have issues with them.