SketchUp 2024 Zoom Extents Zooming at Remote Distance BUG?

In SU 2024, when I use Zoom Extents, the model zooms out to a removed fixed distance. There are no objects off in the distance to create the distance zoom. I have copied a portion of the model to a new 2024 file and the same zoom distance occurs. Does anyone know if this is a change or bug in 2024 or can anyone help me resolve this issue. I use zoom extents to arrange scenes and need the command to work.
Thank you,
Glenn Richardson

Is it possible you share the SUP file?

maybe a hidden line/dot/group/object you overlooked that is causing the zoom to ‘misbehave’?

Probably not a bug. More likely some bit of the model at a great distance from the rest.

In SU 2022, Zoom Extents (ZE) zoomed to what was turned on by the visible tags. Now ZE seems to zoom to include turned off tags in the zoom distance. Is this the way 2024 is supposed to function? Please advise.

Share the .skp file so we can see what you’ve got.

I don’t see Zoom Extents zooming to show areas for parts of the models with hidden tags.

The file is to large to upload. I can share a dropbox.

Yeah. Just share the link.

OK, Thanks. Will take me a minute.

FWIW, this is what I see with Zoom Extents and hidden tags. Nothing different than expected.

Please let me know if this works. Also, if you have any advice ow how to reduce the size of the model, please advise.

Zoom Extents with Site Plan

Zoom Extents without site plan.

I expect it’s this stuff that is causing the problems with Zoom Extents.

The edges inside are tagged and those tags were turned off in the model but the tags groups are not turned off so technically the groups are not hidden so Zoom Extents would include them. You really should be leaving all geometry untagged. Only groups and components should be given tags.

I fixed that in your model.
Screenshot - 4_16_2024 , 10_03_48 AM

As for the file size, number one would be to purge unused stuff from the model. No point hoarding all that unneeded stuff.
Screenshot - 4_16_2024 , 10_05_30 AM
Just eliminating the unused stuff reduced the file size by almost 83%. There is on excessively large texture image which I reduced which knocked off a little more than 1%.

633 Block Model purged.skp (8.7 MB)

Thank you I will go over the model and learn what you did.

I haven’t purged the model because I did not want to loose unused Tags. I have a template with all the Tags and as I design, I assign items to the Tags. I add new Tags, for example, profile builder profiles to new Tags when needed. I have purged materials and components.

I did not realize the column grids geometry were tagged. Thank you.

I have found that when I send the file to Layout and I try to dimension, Layout grabs all over the model and the dimensions are inaccurate. Creating a column grid gives a point for dimensioning in Layout. When I draw the grid in SU, faces are created and the line segments. I turned each line in the column grid into a group so they could be moved separately in the model. Somewhere in this process the geometry got tagged. Any suggestions as to how to create guide lines, ie. grid lines, lines to dimension to, etc in a model. Is there an extension?

Again Thank You for your advice. I have been using SketchUp, not full time, about since it first came out. I am still a beginer and I appreciate any help.

You don’t have to purge unused tags. Just purge unused components, materials, and styles. You can do each of those in their respective inspector windows in the Tray or,as I did, use TIG’s Purge All but deselect Tags.

That should not be the case. You should be able to snap dimensions to the geometry in the model. Make sure you have Object Snapping turned on and Grid Snapping turned off in LO.

I haven’t seen an extension to create what you show but I’ve never found a need for them. Maybe someone else will come along with a suggestion.

BTW, I also found a couple of little bits of geometry at a distance from the model so Zoom Extents would also account for them. Upper left corner where the coordinates are in this screenshot.

Did you use an extension to fix the default geometry?
Besides just looking, did you have an extension to find the stray geometry? I zoomed way out, did selection by crossing and deleted in all directions, so I am curious how you found the geometry.

Yes. TIG’s Default Tag Geometry from Sketchucation.

No. I just select the objects for the house and your grid with a fairly tight selection window. Then I inverted the selection (Edit menu) and looked to see what was shown selected in Entity Info. I used a keyboard shortcut for Zoom Selection to zoom in on them.

Thank you

1 Like