SketchUp 2024 slow viewing existing prev 2023 models

I do quite a bit of modeling in SU 2023. I downloaded 2024 and when opening my larger files, instead of experiencing increased performance, I get very slow orbiting ultimately with a locked viewport which occasionally goes completely black. No crashing. No error messages. It seems to happen less opening smaller models. The models I’m trying to open are big but work perfectly fine in SU 2023 on the same machine. I have no 3rd party extensions installed.

So far 2024 is unusable in this state. Any advice would be appreciated as I’m excited about 2024’s potential.

MacOS Sonoma 14.4.1
MacBook Pro 16" attached to LG 5000k UltraFine monitor
M3 Max chip
128 GB memory

There are a couple of other topics about this. I am investigating M3 issues, and have found that a few of them seem to be related to antialiasing settings. If you go into settings, graphics, and change the antialiasing to 0x, the problems should go away.

The LG 5K screen should be detailed enough that not having antialiasing turned on should still look ok.

thank you for the suggestion Colin but reducing the antialiasing to 0x does not seem to have any affect. The viewport still freezes. I’ve also tried un-installing and re-installing SU 2024 and the issue persists.

Did you close and reopen the document after switching to 0x? Doing that change won’t help the currently stuck document.

thanks for the tip. I just tried it again and closed the document after switching to 0x. Then reopened the file. That seems to fix the freezing problem and I can orbit fine now but the linework looks horrible. Not even as good as SU 2023. Is this issue something that is specific to M3 Max compatibility? Seems weird that I have the fastest mac chip and a high end monitor and these are the results. Any fixes coming soon?

Thanks for your help.

So far I had been the only person who could test the issue, and when the problem occurs there are no errors happening. A few days ago the developers ordered an M3 for them to look into the problem as well. They are not going to see errors either, but at least they have the source code, and can try ideas to stop the problem happening.

So, yes, the plan is to have a fix come soon.

I mostly work with the Retina displays in my MacBook Pros, and so the jagginess of 0x antialiasing isn’t a problem. If you’re on a bigger lower DPI monitor I can imagine it is more distracting. One thing to know, when you export to PNG, for example, the export options have an anti alias checkbox. That does then nicely antialias the lines in the final PNG. Viewports in LayOut also look ok.

It’s not just M3 Max Macs, I’m having the same issues you describe on a Win11 workstation with a RTX4090.
First noticed the issue when I started setting up my toolbars again. Screen would go blank after selecting a new toolbar to add. Zooming or rotating in the viewport would make it go away, but the speed of these actions is horrific, and delayed to boot. This is using a model that is extremely small and simple.

Loading up a more complex model is impossible to work on.

Just trying to select multiple components is a pain. It’s so slow I can’t actually get any work done. Going back to 2023 with the same model and everything works fine.

I was going to try selecting the classic graphics engine, but why do that when 2023 works fine?

Something is definitely amiss here.

Just downloaded Sketchup 2024. SU 2024 is slow and unusable. Windows 10, No graphics card, 16 GB memory. SU 2023 works fine. I’m experiencing very slow and laggy operation on small models, with no extensions from SU2023.

SU2024 is unusable. Going back to SU 2023 and waiting on fix for SU2024.

SketchUp recommends a discrete GPU (preferably Nvidia.)

1 Like

the change from openGL to directX12 or Metal means that in the long run, weaker machines will be left behind. an entry level machine could run sketchup fine, but its lack of discrete GPU will be a handicap when dealing with the new engines.

OpenGL is an obsolete tech from the early 2000’s that could run on a potato with a screen. DirectX is a modern engine that needs a bit more juice to run.
Your computer is running win10 not 11, and doesn’t have a discrete GPU, it’s possible your integrated GPU is not compatible with DX12.
there won’t be a magical fix on that, your GPU is not compatible with the tech used here. Right now, you can switch between the classic openGL engine and the new directX one.

1 Like

Actually, OpenGL (1992) is only 3 years older than DirectX (1995).

It may be more about the constant development put into DirectX vs the change in focus for Khronos Group to the Vulkan API since 2017 (the last and final release of OpenGL.)

One major benefit is that DirectX 12 added support for GPU ray tracing (DXR) which OpenGL lacks (and now will never get.)

exactly, openGL stopped in 2017, but SU runs with an older version (at least on mac it’s 3,2 from 2009) while DX12 and Metal are still being developed and expanded by adding support to new tech.

sooner or later we’ll see a DX13 / Metal4 and chances are SU will later adopt them. meanwhile, it was using a 15y old version of openGL.

1 Like

Since several features have been disabled on anything other than Sketch Up 2024, like the 3D Warehouse and Geolocation, I don’t think going back to other versions is an option now

Such basic issue like the viewport inexplicably lagging with nothing on the screen is just not acceptable, fixing this one must be a real priority

1 Like

Those features have not been disabled for SketchUp 2023 or 2022.

Please update your forum profile. It says you’re still using SketchUp 2021.

1 Like

your profile says you’re using sketchup 2021, that your OS is 2021 and that you don’t have a graphics card.

I think these are valid reasons why your viewport might be lagging.

please give correct infos in your profile, if you want help. if you don’t, then… why bother ? :slight_smile:

like Dave said. there is a 3 year support, 22 23 and 24.

For openGL must I use SU 2023?

Thanks for the help.
Can I switch to the classic openGL engine while running SU2024?
How would I do that?

window - preferences - graphics - use classic engine.

2 Likes

Just ran the System Checkup for SU2024
Results:

Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: GPU OpenGL requirement has been met!
Success: GPU RAM requirement has been met!
Success: GPU Hardware Acceleration requirement has been met!
Success: GPU capability tests have passed.

Congratulations, your computer has met all the minimum requirements to run SketchUp 2024.

My problem is that SU2023 works great while SU2024 is so slow it is unusable.
Am I stuck with using SU2023 until I get a new computer that runs direct X12?

I see this when I run the direct X dialog tool.

It seems to say I have DirectX 12.