Orbit heavy lag with Mac OS X 10.11.4


#1

Hi everyone,
yesterday I updated my iMac with last MacOS version. After that i notice that using orbit tool cause heavy lag even with lighter models. Zoom and pan too seem have the same problem. After trying to update graphics card drivers there weren’t any changes. Do I have to wait for a sketchup update? I’m working with SUPro 16.

Thanks in advance and apologize for my bad english

Andrea


SU 2016 Lag.....all of a sudden
Delay using wacom tablet
Delay using wacom tablet
SketchUp Pro 2015 and OSX El Capitain - Orbit Lag
#2

When you installed 10.11.4, you most likely got new drivers for the GPU. You may need to change OpenGL settings. Try Preferences>OpenGL and untick Use Hardware Acceleration. See if that changes orbiting performance.

By the way, there’s no need to apologize for your English. :wink:


#3

i also updated and I’m not noticing any effect on orbit. What variety of Mac do you have (please fill in your profile info)?


#4


#5

As Steve asked, please complete your profile.

Did you try my suggestion?


#6

It works! Thank you very much Dave; do I have to provide you something like 1KG of Parmigiano Reggiano?:smiley:

Cheers


#7

Excellent!

I surely wouldn’t turn it down. :smiley:


#8

Dave is banned from accepting cheese gratuities directly, they must be sent to me first and I’ll forward it to him. Sometimes significant shrinkage occurs due to unforseen shipping issues.


#9

After update and reading this thread tried toggling openGL hardware acceleration ON/OFF (restarting sketchup) but did not relieve the sever lag using Orbit tool. Opened previous Sketchup 8 to see if there was lag using Orbit but there was not. Would flashing the VRAM do anything? It’s just that Sketchup 8 is smooth so wouldn’t an system graphics driver update, as suggested affect both versions of SKP, Make and 8? Any thoughts?


#10

How complex a model are you testing? Your profile info says you have a rather old graphics card with minimal memory, and that could affect performance on a model with a lot of geometry.


#11

Sorry forgot to mention. Not a model simply an un-extruded rectangle. No other graphics. Or even a completely empty workspace. Still, Sketchup 8 works smooth so I can use that, it’s just that I was going to upgrade to 2016. I will try to work it out

.


#12

Hi there, I’m suffering the same orbit lag on my macbook pro Retina (mid-2012). There is nothing related with the complexity of the model but maybe with some incompatibility of SketchUp 2016 with the new graphics driver upgrade in this new OSX version…?. It shows a laggy behavior too with move, extrude and other tools when you have to interact with objects in the viewport.

The issue began immediately after upgrade to the new version of OSX El Capitan V.10.11.4. I made a downgrade to OSX V.10.11.3 and after that the lag disappeared completely. Until this can be fixed I’m thinking in wait sometime before upgrade to the new OSX version again…


#13

Well,
after turning off Open GL, seems that orbit and pan work better but, not as good as it would be. The bad news is that the model looks very bad and have some problem in visualizing lines and surfaces. I think it is a problem between latest mac os and su2016. Do you think is better for to downgrade or are you ASAP give us a SU update to solve this problem?

Andrea


#14

Same problem here. I switched off hardware acceleration and this fixed the lag problem but as Andrea says, the visual aspect of the model suffers considerably. Going to have to downgrade to the older version of OS X.

Seems a little unfair that Apple’s cockup becomes Sketchups problem.


#15

I wonder if Apple made some incremental step further toward Metal graphics in 10.11.4 and in so doing screwed up OpenGL? There are very few other apps that use OpenGL as intensively as SketchUp, so most users might never notice.


#16

It appears a downgrade is not an option for me so I have to live with the problem! Is this something sketchy can fix with an upgrade?


#17

*Sketchup! ■■■■ autocorrect!!


#18

I updated to 10.11.4 and I’m not having any new issues with graphics…

In the past, turning Hardware Acceleration back ON after a SU restart, seemed to allow OpenGL to then work…

It seemed like it was forcing a reset of some kind…

john


#19

Hello,
I had the same problem with orbiting after update to 10.11.4. Sketchup became unusable. Turning off acceleration doesn’t solve the problem and reseting NVRAM too. I found out It is connected to using SmootMouse software with I use for my bluetooth mouse. When I turned it off sketchup orbiting is smooth again.


#20

Hi Essence75. I use a bluetooth mouse (a Logitec anywhereMX Darkfield) so possibly use smooth mouse software. Could you tell me how and where would I find to turn this off?

The so called lag for me is actually not too bad and SU still functions ok. But with orbit being one of the most used tools, it’s a bit annoying to not have it run smoothly.