SketchUp 2022-0-353-126 on Mac M1 Max - Monterey 12.3.1 - CRASHING ON OPEN

Hi, I recently updated to Monterey 12.3.1 and SketchUp is freezing/crashing every time I open an existing file and/or starting a new file from template (using the standard sketchup templates native to the program). in the attachment you will see my mouse clicks trying to select the menus and nothing happens. for some reason in the video my mouse pointer is not showing the spinning beachball, but that is what i am seeing.
At any rate, I’ve tried reinstalling SketchUp, V-Ray, and also deleted the sketchup plist file, thinking that might be the issue but i keep getting the same resulting freeze/crash. sorry for the low video quailty, this forum only allows for small file sizes.

What is the other extension?

Hi, I actually have a number of different extensions installed, was thinking it might have been V-ray causing problems as that has been one known to cause issues in the past and it has its own installer. I can’t select any of the menu items even if I wanted to try and uninstall or deactivate the other extensions because the spinning beach ball starts up. Something tells me this has to do with the new mac OS update, as everything was working just fine before that installed. I’ve reached out to support, but haven’t heard back yet.

When you installed your extensions, did you get, for instance, the newest maintenance version of V-Ray 5? It was released just a day or two ago. You should at least use the version of V-ray that was released about a week after SketchUp 2022 - older ones don’t work with version 2022.

V-ray is the one that is working on M1, the others I am not sure of, but if you did install them, that would mean you have had them installed through the Extension Manager, which is a menu item.

So, in Finder, go to the User library and rename this file:
~/Library/Application Support/SketchUp/SketchUp 2022/SketchUp/Plugins into ‘TempPlugins’ and try to start SketchUp then.

Thanks, that worked, it’s a plugin that wasn’t loading, now how to figure out which one(s)?

Thanks, I believe it was the newest one, the one I downloaded off Chaos was named “vray_52006_sketchup_osx”… (upate 2.5). If there is a newer one it is not showing up on my account as of today. Although, the above version loaded and is working after I renamed my plug-ins folder as MikeWayzovski suggested.

Difficult to say - adding them back one by one might reveal the culprit.

AFAIK that is the latest one.

Thanks, I appreciate your help.

Will try adding the plug-ins individually - (was hoping not to do that as you can imagine, wishing there was a better more efficient way is all). Given how long sketchup has been around, it’s surprising that they haven’t written some code into the app that allows sketchup to fully load and skip the plug-in(s) that don’t load - As an internet search (while trying to see if anyone else had this problem) reveals that this seems to be re-occurring over the years - this would be a nice feature to add so one doesn’t need to waste their own time and the time of others trying to figure out the problem. Maybe this functionality already exists, but for some reason didn’t work this time? Anyway, thanks again for the insight and help.

1 Like

Don’t do them one by one, do half and if the problem persists try half of those or if the problem goes away try half of the others. Repeat this and if there is just one offender you will zero in on it much faster.

Hi Friend!
I’m thinking of buying a mac m1 max! I’m an architect and I use Sketchup + V-Ray! What is your experience on Mac m1 max? Is render time good? is already running native sketchup and v-ray for mac? I would be very grateful if you could get back to me! Thank you :slight_smile:

Thanks. This is helpful. I appreciate it.

I believe I have found the culprit! I looks to be LibFredo6 v12.8a (from SketchUcation) - which is unfortunate as there are so many great tools which use that library. It looks like that extension was last updated exactly one month ago… LibFredo6 | SketchUcation

Hi, @viniciusramire

I am an Architect as well! I upgraded from a 2016 Macbook Pro which was intel based - which is all that I have to compare to. There is a drastic and noticeable improvement. Everything I am running is noticeably faster, so for me it was worth the upgrade. SketchUp runs “Universal” and V-Ray runs “intel”. but again the improvement is night and day as they say…

hope this helps


I would update Clothworks as it has an issue with Mac and has been updated very recently to address the problem.

Hi @Box ,
Thanks for the heads up. I actually just did. I am guessing this probably has something to do with the new OS update that just came out. Apparently, dropbox is having issues with it as well.

Thank You friend!

yes it helped me a lot! I currently have a 2015 iMac 4k! an interior image to render in the settings below (image) takes about 40 minutes! :pensive:

I will then buy the m1 max! thank you again

@Intricacy I forgot to ask! what approximate time does it take to render in v-ray an image with the specs I sent above on your m1 max? because as I said, mine takes approximately 40 minutes! Thank you :slight_smile:

@viniciusramire it’s hard to tell. There are so many variables involved as you can imagine, ie the complexity of your model, your materials, the lighting setup, etc, just to name a few. at any rate, I’ve been noticing an improvement from my 2016 confuser to my new confuser. something to keep in mind as well when you order your confuser, when I ordered mine I customized it a bit, so it took some time to receive as well. I ordered in November, and received it in January. anyway, good luck to you.