Sketchup 2020 licensed

We have been running SketchUp 2020 since it came out. Today it not working and is saying its not licensed. What can we do, I need to let out IT people know how to fix this.

That message will appear if you have had SketchUp open during the time that it has been more than 28 days since you signed in. It also would happen if your account admin had deauthorized all devices.

In both cases you solve the problem by signing out and signing in again. If it was the 28 day case you should be able to continue working. If all devices had been deauthorized, you may still be ok, but if there is a message about too many authorizations, you would need to find out who else is signed into your subscription.

Still getting the same message. I don;'t understand what is meant by “Signing in”, We close and open the program all the time working on various files. That is the extent of what we do to sign in, should we be doing something else?

I got a sign in page

and signed in, but now I getting this;

do i have to put in the license again ?

…are you telling me we have to put in our information every 28 day for our perpetual permanent license form now on?

When you installed SketchUp 2020 (and 2021, which your profile says you are using) did you right click on the downloaded installer and select Run as administrator? It may be that due to a Windows update there’s a permissions issue preventing the license sign in from being saved. That’s been seen before.

That’s a thing for the Subscription license.

If you have a Classic license for 2020 you should not need to sign in. Just add the license key and serial number.

this is controlled by our IT department, us users cannot install programs. that being said i give them instructions on doing just that.

This is a classic version that we have been using for the past year.

Does that mean you’ve given them instructions to do that? Or you will give them instructions to do that? It should also be installed under the user’s login using the Run as administrator option from the Context menu.

sorry,
yes I gave them the link to instructions from the sketchup site and told them to use the “Run as administrator” when installing.

Again, if there’s a Classic license, the serial number and key are required. Is this a multi-seat license, though? That licensing is different.

This is a multi-seat license. but if this was done when they were installed why would it change now?

Probably a permissions thing with a Windows update. Or did your company update the license? @colin could probably tell you that when he gets into the office.

The classic network license is managed by Trimble’s servers and it requires that certain Internet ports are open for the users. Some change in your settings might have closed the ports.

1 Like

Thanks Anssi,
I have sent this message to our IT department,

DaveR,
yes we have been talking to Colin, I hope when he gets in he will call or email our contact in our IT Department and help them solve this. In the meantime we are dead in the water…

Do you know which ports its needs to be?

There is still a help page, it mentions ports 5053 and 50530

https://help.sketchup.com/en/sketchup/administering-network-license

Thanks,
we check and they are open.

About the classic network license:
If you bought a license in 2020. You probably are entitled for a 2021 version, too.
If somebody ‘tried’ that version, there is a 2 month period where you can use both versions.
After that, only the last version can be active.

Did someone tried the 2021 version?

I did work in support for two years, but don’t now. I do answer questions in the forum, but I don’t have access to the support system anymore. Someone else is likely to get in touch.