SketchUp 2018 won't launch no errors codes just doesn't launch properly


#1

Whenever I launch Sketchup 2018 via the start menu it will display in the taskbar but no windows for it will display. I have attempted to use the WinKey+Left to cycle it through the screens to see if it would display. I have also uninstalled and reinstalled the application and it has not done anything. If I cancel out that splash screen from the taskbar (since I can’t find it) or open an skp file it will launch but the only tool that will do anything and even it doesn’t work correctly is the Selection tool.

Any ideas of what I can do to get Sketchup to work? It had worked on a very similar Surface device.

Attached: SketchupFailuretoLaunch shows the taskbar issue.

SketchupFailuretoLaunch


#2

(1) Find the installer exe, right-click it and choose “Run as administrator” then choose “Repair”.

(2) Update graphics driver from …
a. your computer OEM
b. Intel directly (latest is 29-Aug-2018)

(3) There is a patch for 2018 to overcome the “slow select tool” issue …

(4) Did you have any external displays previously plugged into your machine, and if so had you set the external display to the the “primary” display ?

I myself had SketchUp hang when it was opening on my internal notebook display which was set as the “secondary” display when an external monitor was plugged in. It was a rigmarole to get things working correctly again.

(5) If you can get SketchUp running and get at the Preferences > OpenGL panel, switch OFF “Fast Feedback”. (It seems recent 7th and 8th generation Intel HD 6xx APUs do not like Fast Feedback.)


#3

And report back if you get it working.


#4

Thanks Dan. It was the Intel driver that caused the issue. Apparently on this replacement computer it was just using OEM drivers and it wasn’t registering the graphics card properly. After installing the Intel Driver I was able to at the very least run SketchUp off docking station which is a step in the right direction. I’ll have to try the docking station setup later.