SketchUp 2017 Select and Zoom tools have long delays

I can find posts relating to this problem that goes back to 2017 but nothing recently. After downloading SketchUp Make 2017 to my computer it worked perfectly for about five days. Now, anytime I click on the Select or Zoom tools (red block with magnifying glass) the action is delayed and the Select tool really doesn’t work. I’m running Windows 10 with an Intel HD 4000 graphics card which is up to date. Using the web based program has none of these problems. Would love to keep learning this new program but the lack of the Select tool is making it difficult.

Did you install SketchUp correctly by right-click the installer and choosing “run as administrator “? Failure to do exactly that can lead to a wide variety of strange errors.

1 Like

I don’t remember if I chose “run as administrator” or not but it worked fine for a few days. I’ve since un-installed and re-installed the program and the problem remains. I’ll repeat the process again and choose the administrator option and report back.

If that doesn’t help, try unchecking “use fast feedback” in SketchUp ‘s OpenGL preferences

One more thing, you can also hit the “repair” option and you won’t lose your extensions if you have any installed.

There have been numerous threads about slowness with the Select and other tools. The common problem has been the inadequate integrated graphics adapters, especially those from Intel. Updating graphics drivers has helped some users and it’s worth a try. Keep in mind that automatic Windows updates frequently include updates for the Intel graphics drivers and they often break things. You have to watch out for that. If you find a driver direct from Intel that works well, keep a copy of it so you can roll back to it if a Windows update replaces it.

Installing correctly using Run as administrator is important, though, so making sure that is done is a good idea.

Just re-installed. Never saw an option to click on “run as administrator.” The re-install didn’t make any difference - neither did unchecking “use fast feedback.” Where is the “repair” option? I ran the “checkup” and it came back all good.

You have to right click on the installer file and select Run as administrator from there. Make sure SketchUp is closed before you do this and after clicking on Run as administrator, you should be offered the option to Repair. Choose that.

1 Like

Ran as administrator and did the repair option. No luck.

I didn’t expect that repairing the installation would have any impact on the slow selection thing but there are other potential issues that you have now headed off. Since the problem you report is specifically related to graphics drivers with inadequate OpenGL support, you really need to be looking there. Have you tried updating the graphics drivers directly from Intel? If you have and haven’t seen any improvement, one option would be to try using SketchUp Free instead. It uses a different graphics setup and may work better for you. Another option would be to go back to SketchUp 2016 Make. It allows you to turn off Hardware Acceleration which dumps rendering duties to the CPU instead of relying on a graphics card that isn’t up to the task. While this might work for you, it’s important to note that you won’t be able to download files directly from the 3D Warehouse. If you don’t use components or models from the 3D Warehouse that’ll be no big deal. The real ideal thing would be to upgrade your computer with a decent graphics card. Doing that may mean upgrading to a new computer, however.

If it was the graphics card why would it have worked for about five days?

There may have been an automatic Windows update installed recently. There’s been many reports of the same thing you have described over the years. I’m relaying to you what the culprit has been in those cases. You certainly could have something else going on but the graphics card and it’s drivers are the most likely problem. Integrated Intel graphics are well known to be inadequate as far as OpenGL support is concerned and integrated graphics are not recommended for SketchUp. Until you repaired the installation a little while ago, SketchUp 2017 hadn’t changed. It hasn’t changed in almost 2 years.

There was a Window’s update at the time it quit working right. How do I identify which update is the culprit?

I’m not sure how to tell you which update but instead of looking, first go to the Intel site and see if they have a new driver for your card. Download and install that and see if there’s any improvement.

By the way, that is the common denominator between your report and all those other ones.

1 Like

Although my computer said my graphics card was up to date the Intel site said otherwise. Downloading the update from Intel SOLVED THE PROBLEM!!! Thanks so much Dave

1 Like

Very good. Thanks for the update.

Your computer told you the drivers were up to date because it’s Windows looking only for the drivers it installed.

Considering this was the fix, it would make sense to one, keep a copy of the driver you got from Intel for the next time a Windows updates installs bad drivers and b, After Windows updates, just go to the Intel site and check yourself for new drivers.

1 Like

I’ll do that and thanks again.

1 Like

intel Driver & Support Assistant

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.