Select tool delay, and doesn't create box around objects


#1

I’ve downloaded SketchUp Make 2017 to a new device, but the SELECT TOOL now takes a number of seconds to select an item (or items), and no longer creates a box to surround and select multiple items, making it impossible to do accurately. Any help would be appreciated, as this multi-second delay every time you select anything, drastically increases the time it takes to complete a task. Thank you.


#2

There are many threads on this topic already. Have a read.

Did you install SketchUp 2017 correctly? That is, did you right click on the installer EXE and choose Run as administrator? Or did you just double click on it to get it to run?

Make sure your graphics drivers are updated. Check with Intel for updated drivers.


#3

I’ll take your advice and have a read, thank you. Everything else works fine, I did ‘run as administrator’, and even tried uninstall/reinstall with the same results. Cheers


#4

The common issue for others that have reported this problem is the Intel graphics drivers. Updating the drivers sometimes helps. Sometimes it takes rolling them back to an older version. You’ll need to stay on top of automatically pushed Windows updates because they frequently make the problem reappear when they screw with the graphics drivers.

If you have an option to do it, you should add an Nvidia graphics card and use it instead of the integrated Intel graphics.


#5

You’re a gentleman Dave, thanks for this, much appreciated! :smiley:


#6

Thank you.

Good luck.


#7

This happens often on my notebook after almost every Windows 10 update. I’ve tried all the recommendations numerous times. Re-boots usually fix it now. It’s the first thing I do when the select tool lags now. Sometimes it might take 2 or 3 restarts but that is a lot faster than doing any of the other remedies.


#8

Thanks mics, I’ll give it a try.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.