Trouble with select tool lag

Ive just started using the free desktop version. Ive used Sketchup previously. When I click select tool to highlight a area or object I do not see anything happen. If I wait 20-30 seconds a section of the area will highlight. Not working correctly.

What browser are you using? What graphics card?

Please update/complete your forum profile.

Im using the desk top version, so it doesnt use a browser, correct? otherwise I typically use Chrome or Firefox.
I tried to find what I have for a graphics card but didn’t see anything listed like that in devices.

Ok, what I see is Intel ® HD Graphics

You posted in the SketchUp for Web/SketchUp Free category. That confused the issue.

The computer has to have a graphics card of some sort. You added the Intel graphics thing while I was responding. Go to the Intel site and update the graphics drivers for your GPU. Most commonly the problem you report is due to bad graphics drivers that were included with a Windows update.

FWIW, integrated graphics cards like that have never been recommended for SketchUp.

I’ll move your thread to the right category.

very good. Thanks

I went thru a bunch of mess trying to upgrade my graphics driver only to find I had the latest update.
Anyway, I downloaded the Sketchup Pro free trial. Everything, including the select tool, worked as intended. No problem at all.
So the problem must exist in the free program.

Perhaps a combination of your graphics card/drivers and the graphics pipeline used by SketchUp 2017 Make. Back when SketchUp 2017 was the current version there were other reports of lagging with Intel integrated graphics. There have been changes in the graphics over the years. At this point, however, it’s safe to assume that 2017 Make won’t get any changes. You could use SketchUp Free as a hobbyist, though.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.