Slight lag time in select tool in sketchup pro 2018?

Hi gang, I just downloaded skechup pro 2018 and it seems I have a lag time with the select tool?

Is there a quick fix for this?? its really annoying :slight_smile:

Thank you

Jay

See the myriad threads on this topic already.

Check in Window>Preferences>OpenGL to see what graphics card is being used. Make sure its drivers are up to date.

What is your graphics card? Your profile says it is “12” which doesn’t make sense.

thanks Dave! My graphics card just says Intel ® HD Graphics

Does this help?

Jay

A little. As I wrote, try updating the graphics drivers. It may help. Otherwise you might have to roll the drivers back to an earlier version. Intel HD graphics are noted for lack of adequate OpenGL support. Search for ‘Select slow’ and read through the various threads.Also read the sticky thread at the top of the forum.

thanks Dave and sorry for being such a pain!! I updated the driver and it says it is working properly. When I tried to “click” on the roll back driver it is not letting me click that option?

You think I should uninstall it and install a better more compatible graphics ?

Jay

That graphics chipset of yours is waving a red flag of potential problems - but at least SU18 does load. Read the sticky post?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.