Very long lag and delay when selecting things. and other annoying things

I am using Sketchup Pro 2018 on a Microsoft Surface Book Pro with an Nvidia GeForce 1050 graphics card. Whenever I try to use sketchup, there is an painfully long delay when trying to select things. I read somewhere in a forum post from a couple of years ago that it might be my graphics card driver might be out of date and needs to be updated. It’s not that. I checked. Need to know what else might be causing that problem.
Also, I can’t triple click on geometry to select the whole thing and all connect parts like it’s supposed to. I have to do a frame select if I want to select a whole piece of geometry. Super annoying. The best I can get it to do is select a single face and it’s outlines.
The other really irritating thing that’s happening lately is when I go to the help tab and select License, Like when I need to get my serial number to tell tech support about what’s happening, the whole thing freezes and I have to restart the whole computer to get the software to close. SUPER annoying.
What can I do to get sketchup working the way it’s supposed to. Thanks

try if disabling “Window > Prefrerences > OpenGL > Fast Feedback” helps.

the license dialogs are browser-based (Chromium) and need to ‘talk’ with the Trimble license server. If limited user rights or an over-motivated security solution is blocking this, the issue you have described may arise.

Re-install SU by launching the setup routine by “rclick > Run as Admin” and ensure, that internet access (single user license: ports #80/8080/443 open) is granted to the used user account.

btw, OpenGL support (and speed) of integrated intel HD graphics sub-systems is *beep * and not made for the use with 3D modelers, go for a dedicated GeForce GTX for your next device.

Check in your Nvidia control panel 3D application settings that SketchUp is set to use your Nvidia card. You can also check in the Window menu>Preferences>OpenGL dialog in SketchUp which graphics system is currently being used.