Very slow and freezes after select tool


Hi new to sketchup and have the trial version installed. Everything works great except the select tool is very slow and sometimes freezes and make the program unusable at all.

I have a Surface Book and all the MS updates up to date and have the latest drivers for my display cards.



Make sure that the Nvidia card is selected to be used by SketchUp. Open the Nvidia control panel for that. Intel graphics are notorious for issues. There’s also a patch that can be run that might help. See:



Tried designating the GPU to Nvidia but that doesn’t help. How do I run the script in the second option? If opens a line of text in Dropbox only.


Click the Download button in the upper right corner of the DropBox screen. After it downloads, double click on it to run it.


I’m still having this problem, and none of the fixes have worked for longer than a single restart. ive been using sketchup since SU6 in 2007, and honestly this problem, along with the troubling decisions in regards to SU make trimble has made, is making me consider migrating to form-z or something similar. The only thing thats keeping me around anymore is that my model library is all SU files.
If anyone at all has figured out some way to fix this problem permanently short of just getting a different computer, I’ll be quite grateful.



Could you please provide the fix for select tool freeze again please? It says that the file isn’t available anymore.


Sorry. I don’t have access to the file. I was only sharing the link in my post above. Maybe @ty_s can share an updated link to it.


Other forum posts have mentioned getting your Intel driver from Intel, not from a Windows update.

As you have an NVIDIA GPU, make sure SketchUp is using it - Window>Preferences>Open GL>Graphics card.


I/we are working on getting this back online.


You can download the script here:


Thank you. I found it from ty_s