[Skalp] Load error in SU17 (with version 1.2)

mac
skalp
encoding
encoder
rubyencoder

#1

Since I started using SU17 yesterday, I have been getting the error message below. Does anyone know what it means? It doesn’t seem to affect performance (or maybe I have not yet encountered the consequence).

Error Loading File /Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp/Skalp_loader.rb
Error: #<LoadError: The RubyEncoder loader is not installed. Please visit the http://www.rubyencoder.com/loaders/ RubyEncoder site to download the required loader for ‘darwin’ and unpack it into ‘/Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp/rgloader’ directory to run this protected script.>
/Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp/rgloader/loader.rb:21:in <top (required)>' /Applications/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:inrequire’
/Applications/SketchUp 2017/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in require' /Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp/Skalp_loader.rb:6:in<top (required)>’
/Applications/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in require' /Applications/SketchUp 2017/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inload’
/Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp.rb:78:in register_extension' /Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp.rb:78:inload_extension’
/Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp.rb:126:in <module:Skalp>' /Users/sevans/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Skalp_Skalp.rb:25:in<top (required)>’


#2

Did you install the new beta version of skalp that has been released for 2017 or did you just use an old version?
If old version, uninstall it and get the new version.


#3

I reloaded Skalp from the Extension Warehouse. I don’t know what version that is. but thanks for pointing out the possible source of the error. I admit I haven’t tried using Skalp since I started using 2017.


#4

Have a look here.


#5

It’s Skalp version 1.2.0062. Extension Manager tells me the Signature is outdated. I don’t really know what that means but nearly all my extensions have that.


#6

Ah, that seems to answer it. Thanks for the advice.


#7

Have downloaded and installed Skalp 2.0 Beta. SU crashed in the process but on re-loading it looks like the new version is in Extension Manager. However, I can’t dee the usual palette or any mention of Skalp in the menus. Looks like more digging is needed!


#8

Simon,

We could do a teamviewer screensharing session. That way you could show me your issues and then I could take over and help you along.

If you like this idea: download from teamviewer.com, start a new session and send me your 9 digit session Id + password. (guy@skalp4sketchup.com)

Kind regards,

Guy


#9

Guy, that’s really kind. I’ll do that, but it could be that I have just not looked hard enough so do tell me if I need to check on anything. In the meanwhile I will visit teamviewer.

Simon


#10

Problem sorted as a result of Guy’s invaluable help. Looked like a sequence of uninstalling and reinstalling did the business.