Signin Error

I have found the source of my problems. It may also help you. Our school web filter client was restricting google apps to only those approved for our domain. Once I removed that restriction, Sketchup was able to load and approve the credentials. You will still run into issues if you haven’t approved pop-ups for the website but that is an easy fix once you gain access through the filter.
Fortunately, I am a tech director as well as a teacher. So I was able to go into the school filter and remove the restriction.
Attached is a screenshot of what my filter setting looked like. Send this info to your tech person and hopefully they can at least temporarily change this (or similar) setting to give you access to the sketchup app again.


Thank you for sharing your findings.

We have the same issue at Glandorf Elementary as other schools here, and we have had this issue for a little over a week now.

My name is Joseph Potthoff and I am the Tech Support Specialist at Glandorf Elementary, which is part of the Ottawa-Glandorf Local Schools District. We have many of our computer classes between grades 6-8 that use SketchUp for Schools as part of their curriculum. Up until last week Tuesday, everyone was able to log into SketchUp for Schools with no issue. But recently we have had an issue with students getting a Sign-In Error when they try to log into or get into SketchUp for Schools so they can work on their projects. I have had entire classes of 20 students, and grades of nearly 75 students not be able to access or even log into SketchUp for Schools. This Sign-In Error just keeps having the student click their name and account, and it will continue to loop after they click on their account, instead of actually logging them into SketchUp for Schools. I have tried restarting the device, resetting the device, clearing the cache and cookies for each user, allowing pop-ups and redirects in each student’s browser. Nothing has worked. The students need to be able to get into SketchUp for Schools since much of their computer class is built around this product. Please can you help solve and fix this issue. Thank you and have a great day!

Sorry to hear that you are having difficulty @potthoff.j. I normally recommend stating off with a few basic steps but you seem to have already taken care of all of them so we can just jump ahead to some of the more advanced steps. I’ll message the rest of the team and see if they have any suggestions that might help while I dig into the database and make sure everything is working as it should on our end.

In the meantime, if you can post a screenshot of exactly what you are seeing that might give me a little more information. Additionally, if you have a custom domain you can share with me, I can take a look at the database and make sure you have permission to access the app.

Do you have any web filters?
See this response Signin Error - #36 by pvigil

Complete ■■■■ show. Everyone having the same issues logging in

Same problem for ONE student account so far for us at . Other accounts are logging in successfully (at least they were yesterday 3/6/23).

Using a Chromebook / Sign in with Google, is not able to login. He is redirected to sign-in error. All Pop Ups have been allowed for the user’s OU. We are using a G Suite for Education account. I am the administrator, and I have installed Sketchup for schools on our domain via the Google Admin Console. All other students at RITS are able to login using “Sign in with Google”.

1 Like

Following for same exact issue.

This is also happening at our school - he have one literal student who can not get in. We tried everything and can confirm it is not the Google account. We also tried multiple devices and browsers and the result is always the same - the infinite loop. I tried to put a ticket in, but I was directed to the forum instead.

@dcyfalted @Lark @Chelsea Have you had a chance to verify the account settings for the individuals that have been affected? We worked with a user last week who discovered that one student had deactivated “Sign-in with Google” for their account, and so the app was being refused. This will likely affect any instance in which they would generally use Google sign-in, and would hopefully be a quick fix.

You can verify this by navigating to Chrome’s browser settings while logged in with the student account, and then following this path:

  1. Open “Manage Your Google Account”

  2. Select Security and then Signing in with Google

  3. Verify that Google Account sign-in prompts have been enabled

Please let us know if any of you see success with this suggestion.

1 Like

This worked for me - thank you!!


Eureka ! This solved the problem for me, too ! Thank you !

1 Like

Here is how we worked around this issue:
When they get to the error screen…
Click on sign in with google
confirm email
on next screen cancel sign-in then click continue
If a popup appears scroll down and click “allow”
Sketchup should open each time.

Yes its an odyssey, but it works.

Thank you for the post. This solved our issue. I’ll make sure to note this down for future use.

Thank you!

Fixed for us finally!!!
The issue for us was that students had classroom data access disabled in google admin.

This box MUST be checked or it will simply not work.

Looking forward to getting sketchup going for our school.

Thanks all

I’ve signed up to this forum purely to thank you for sharing the solution!

I’ve lost count how many pages I’ve had to scroll through to find the answer and it all comes down to one little checkbox!


1 Like

It works! Thanks CoachO!

1 Like

Thanks so much for this… Fixed!!

1 Like

Getting the same issue:
SketchUp for Schools is once again available for educational use only. Don’t worry, any projects that you may have created through your personal Gmail or Microsoft account can still be downloaded from your Google Drive or One Drive. To continue sketching, please log in with an EDU domain account.
I’ve used it regularly for 2+ years with rare occasions of this issue but it seems neither my students nor I can access Sketchup for Schools at this point.
HELP please

Can you please check If popup blockers are showing next the URL? You mush allow popups. Also, please review this thread for what other users had to do to resolve the issue.