Sketchup Education SIGN IN ISSUES

High School teacher here. We have downloaded the Sketchup Educational version program on my students Google account. However, once the student opens the application and the pop-up window requested a sign in, they sign in with their account and the system takes them on a vicious circle and repeatedly requests a sign in. Reached out to trimble and they added the domain to their accessibility, but it did not resolve the issue. How can I get past this? (I can sing in under the teachers account with no issues.)

1 Like

Hi @ksadelski, thanks for the post and welcome to the forums. I am sorry to hear you are having difficulty with the SketchUp for Schools app. My first guess is that a bad cooke or cached file might be the issue. You could try clearing those out and seeing if that fixes it. If that does not get them up and running, I would guess the next most likely cause is a bad deployment. Just re-deploying the app might fix it.

Can you start off with a quick clearing of the cache and cookies first and let me know if that does anything to help?

Also, can you let me know what your domain is? I can manually check the database and make sure it got added correctly just to make sure that is not an issue.

I have the same problem.
I am able to log in but my students always see the same screen saying “Are you in the right place?”.
I have cleared the cache, enabled pop-ups, but no one can log in.
I am the administrator of our Google Workspace for Education, I have uploaded the app to the domain and authorized it for all organizational units.
Can you help us?
Our domain is

Our school district is having the same issue, except our error says “Access blocked: Your institution’s admin needs to review SketchUp.” Error 400: access_not_configured

I have:

Granted Data Access in the Google Admin console
Had SketchUp safelist our domain (
Cleared cache/cookies
Allowed cookies and pop-ups
Uninstalled / Re-Installed Sketchup Schools app via the Admin Console

Hi @kriosct75 and @MarkB-LW. Thanks for the posts. It sounds like you are both having errors but the errors may be different so I’ll address each of you individually.

First up I’ll start with you kriosct75. I am sure you are already aware but there are differences between an admin and a super admin as far as google is concerned. SketchUp for Schools must be deployed via a super admin. Can you make sure you are deploying it via a super admin? If you already did that and are still getting the error, let me know your school or district website and verify that you are a k-12 school (just a simple “yes we are a k-12 school”) is all we need) and I’ll get you added to the database.

As for you MarkB-LW, I am not familiar with that particular error and you have already run through the usual troubleshooting steps so I’ll go ahead and call in an expert and see what @Tori_SU has to say about it. Hopefully we can get a answer quickly.

Hi, thank you for your support.
I’m the super admin of my Google WorkSpace for education.
In the attached file you can see the setting of the SketchUp for School in our Gsuite.
Our website is, yes we are a k-12 school.

See you!

Ah, wonderful to hear back from you so quickly @kriosct75. I’ll go ahead and get you added to the database right now and hopefully that is all we need to do. If you are still seeing any issues, let me know and we can start troubleshooting right away.

Our web site is but our google domain is

Thanks a lot!

Have Sketchup For Schools Deployed but stuck in the Authorization loop that keeps bringing me back to sign in with Google. This is the same for any user in our domain. Could you whitelist our domain please?

I would like to use sketch schools next semester. I am currently getting the loop that everyone refers to in this thread. Can you check to see it the app is whitelisted. I am new to this school an unsure if it has been used here before. I used it for years at my old school.

Wow! Lots of replies in this thread this morning. I’ll try and address everyone all at once in this post so just look for your username for the part that is most relevant to you.

First up is you @kriosct75. I have added you to the database so you are all set to deploy the app. Just make sure not to skip any steps in the deployment process as that will lead to errors later on.

Next up is @RSDTech. I have confirmed everything I needed on your website and added you to the database as of a few minutes ago. All you need to do now is to deploy the app. Just don’t skip any steps as that will cause issues later on.

Finally, I’ll address you @erik.mylenek. You are not in the database at the moment but I can add you right now and once this post is live you will be all set to deploy the app. Just make sure not to skip any steps as you deploy the app as that will cause issues later on.

In case any of you need instructions on deployment of the app, I have linked videos in this post that should help you out.


I had already had the App deployed prior to our correspondence for all users in our domain – (not sure this has any bearing). After the changes on your end, I once again verified my deployment as shown in the attached screenshots – however, I am still caught in an authorization loop.



Good afternoon,
Thank you for your reply. I tried all tehse solutions iwth multiple student. My school domain is and thsi accoutn works, howevre teh student are under a different domain and theirs does not. Please make sure it is added.

Hi @ksadelski , thanks for the post and sorry to hear you are still having issues with SketchUp for Schools. I verified that you are added in the database and while I was verifying things I also pinged the server to make sure it was working and all appears to be well so we can safely rule all of that out as a potential cause. We can start troubleshooting to get you up and running by re-deploying the app on the domain that is not working just to rule out a bad deployment, but before you do that we will need to make sure the cache and cookies are cleared out just to make sure we have a clean install without any previously generated files to foul things up.

Can you clear the cache and cookies out and then redeploy the app on the student domain to see if that helps at all? Once that is done, if you are still not up and running we can start some of the more advanced steps.

Hi! I am having the same issue as some here. I Have Sketchup For Schools Deployed but stuck in the Authorization loop that keeps bringing me back to sign in with Google.

Also still caught in the loop. I am able to install so it must be on our domain. Unsure how to proceed.

Hi CaseyG. New to Community and have also had issues with initial sign on. Followed all instructions you’ve reflected so far for this issue, including correct installation and permissioning. Using Google SSO. Can you confirm our domain is whitelisted and let me know? Thank you.

Hi Casey. I was prompted by SketchUp to post again here to hopefully get your attention. I’m running into the same exact issue as RSDTech here. Identical screen shots and can confirm all other troubleshooting steps have been executed. Does my domain need to be whitelisted in order for me to get out of the sign in loop? If so, could you execute that for me and let me know when done? Thanks for your help.

I tried clearing Cachet and turning off the pop up and nothing. We literally sit in a row of 20 students and try everything, laptop, desktop, macc, PC. Why is it that it works on my domain but not the students domain @nycstudentsnet . The process is frustrating, anyway you can call me?

Hi everyone and sorry for the delay in the reply. I’ll address everyone here in a single post so just look for your username for the part that is relevant to you.

FIrst up is @LisaLHPS. It is possible that you are getting caught in the firewall that protects our app. If you have already followed all the other steps outlined in the thread I’ll go ahead and manually override the firewall to get you access to the app. By the time this post is live the database should have refreshed and you should be up and running. Just let me know if you are running into any additional issues and if so we can try and set up a call to get things figured out.

As for you @ksadelski It seems like there was an issue with your entry in our database but it should be resolved now. Go ahead and let me know if you are still running into issues or if the manual override I entered in the database has fixed it