Shortcuts won't save


#1

Hi
Running SketchUp Pro 18.0.16976 on a new iMac 21" 2017, on OS 10.14.
I like to use Shortcuts, for example Shift H to Hide rest of Model in component edit.
But they won’t save. I set them up under
Preferences > Shortcuts, but if I quit Sketchup they are gone when I restart.
Help


#2

Does this thread help? Key board shortcuts not staying


#3

Reinstalling SketchUp might help. It worked for me, except for getting it to save the textures in my paint palette.


#4

Unfortunately not. It’s mostly about moving prefs from Mac to Windows, and the .plist file they talk about doesn’t appear on my Mac - I can find lots of old plists from previous versions of SketchUp, but no current plist.


#5

You’re right. I can’t find Shortcuts.plist in 2018 either. I can if I go back to 2014. So they must have decided to store them elsewhere.

Maybe as @Forestr suggests you just need to reinstall?


#6

This may also help: https://sketchucation.com/forums/viewtopic.php?f=180&t=68712


#7

Your post mentions macOS 10.14 Mojave. I wonder if this is an issue with the new OS version. I haven’t installed Mojave because there is no driver for my 3DConnection Space Navigator yet, so I can’t check this myself.

The shortcuts are no longer kept in a .plist file, instead they are now in the SharedPreferences.json file that @simoncbevans image shows. As an experiment I’d try quitting SketchUp and then deleting that file. SketchUp will regenerate the default the next time it starts. See if that heals the problem.

Edit: Shortly later I happened across the following article, and it led me to wonder whether SketchUp is also falling victim to this new security feature of Mojave:


#8

no luck I’m afraid. I don’t get to see a prefs file as per @simoncbevans screenshot, so i can’t delete it.


#9

You are looking in the wrong folder, that’s the system-level /Library. You need to look in your personal ~/Library folder. It is hidden in Finder by default, so you likely need to use Finder’s menu Go->Go To Folder to get there. You can also make your Library permanently visible by checking the box near the bottom of Finder’s View->Show View Options dialog.


#10

I’ve been running Mojave since the early beta versions, and haven’t encountered any issues with SU 2018 saving preferences.


#11

Steve may be right about it being the wrong folder although your path looks very similar to mine. But, assuming he is right (and he is a Sage after all!), if the file is missing it probably explains the problem you are facing.


#12

Simon. I can’t be 100% sure what folder you looked at because you image cuts off at the left, but there is no doubt about where @paulr was looking. His image shows the full path starting at Paul’s Mac, and it is the wrong folder. The .json files are definitely in each user’s

~/Library/Application Support/SketchUp 2018/SketchUp

#13


#14

Yep, that’s ~/Library


#15

Sorry, yes, i was in the wrong folder.
The good news is that I made my library visible, and then found and deleted the .json file.
restarted my mac, restarted sketchup.
Changed the shortcuts in preferences,
quit sketchup.
restarted sketchup.
shortcuts gone!

so yes it sounded like a good fix, but it didn’t work i’m afraid.


#16

But after you delete the file, wouldn’t you have to repopulate a new file? I mean by remaking your shortcuts. Then when you shut down and re-open, they should get held. In theory.


#17

If you delete the PrivatePreferences.json file, it should get recreated when you run SketchUp again.


#18

But you would have to recreate your custom keyboard shortcuts, correct?


#19

Yes, the custom keyboard shortcuts would need to be recreated.

EDIT: keyboard shortcuts are stored in SharedPreferences.json


#20

Yes to all! I deleted shared prefs. Then quit and restarted. I opened shortcuts and added two custom entries.
Tried them on a drawing they worked.
Then quit. And restarted SketchUp.
They were gone.
:frowning: