Key board shortcuts not staying


#1

I have a licensed copy of SU PRO 2015 for Mac and I have modified the keyboard short cuts 3 times, but they return to the default when I restart the program. The first time i thought I forgot to put them in. The second time I thought I was loosing my mind and the third time confirmed it.

I use SU on a Mac at home and a PC at work. I would like to export and import any short cuts to multiple computers if possible. Can this be done?

How do I save them?

What is the problem? I have verified my licenses are current for all computers.


Shortcuts won't save
#2

Yes, you can save the shortcuts and exchange between your Mac and PC.

Windows way


#3

There are no import or export buttons on the Mac. The shortcuts are kept in a plist file that is kept constantly up to date. The format of the file is different than what is exported/imported on Windows. I once wrote a converter to do the translation. I’ll have to see whether I can find it…


#4

Does anybody know where to find the plist?


#5

~/Library/Application Support/SketchUp 2015/SketchUp/Shortcuts.plist

(replace 2015 with 2013 or 2014 if you are using that version)

You may have to use Finder->Go To to get to your Library folder - it is hidden by default.


#6

The attached is the importer I wrote to get shortcuts to the Mac from the file that Windows exports. Instructions on how to use it are in the comments at the top of the file. As the instructions note, this is experimental. Please make a copy of your plist file before trying this.

importprefs.rb (3.6 KB)


#7

I didn’t know Mac doesn’t have these buttons.
Take a look this plugin. importprefs.rb (3.6 KB). Maybe can help you.

See this post

item 5 - it *must not* be running when you do this step. SketchUp only reads the Shortcuts.plist as it starts, and overwrites it when it quits.


#8

It sure is hidden. Library is not even under Finder>Go. I found a Library, but no Sketchup listed.


#9

Finder->Go->Go to Folder


#10

I did that too and it said “library” could not be found.


#11

Try ~/Library

Folder names are case sensitive, and Go To Folder requires a complete path.


#12


#13

You are looking at the “/Library” system folder. You want “/Users/yourname/Library” ("~" is shorthand for your home folder /Users/yourname)


#14

I tried looking for the user library, but it would not show until I tried the “~/Library” from the HD.


#15


#16

I opened the Sortcuts.plist and it was “locked” which may be why it would not save?


#17

Opened it with what? And what indicated it was “locked”?


#18

If you navigate Finder to the file, select it (single click) and right-click “get info”, you should be able to see if the file is locked and, assuming you have permission, clear the lock. Check the permissions at the bottom of the info window to be sure you are allowed to write to the file - that could also be a problem.


#19

TextEdit to see what it looked like. On top of the window, it said “Locked”. So I clicked “Locked” and it gave me the option to unlock. Then I closed it. Changed a few shortcuts in SU. Closed SU and opened again. The changed shortcuts stayed as I had changed them.


#20

That works too.

Thanks for your help.